Brake lights not working - Pontiac GTO Forum
Pontiac GTO Pontiac GTO Forum

» Auto Insurance
Wheel & Tire Center

Go Back   Pontiac GTO Forum > The 1964-1974 Pontiac GTO > 1964-1974 GTO General Discussion
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

GtoForum.com is the premier Pontiac GTO Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-17-2013, 06:31 PM   #1 (permalink)
 
gotyorgoat's Avatar
 
Join Date: Jun 2011
Location: Denver
Posts: 104
My Photos: (0)
Brake lights not working

My turn signals work fine, but my brake lights are not working. I have tested the continuity across the switch at the petal and it seems to be working fine. I have also looked at the fuses which seem to be fine.

Does anybody have any advice on this? If it were a grounding problem, the turn signals wouldn't work either, correct?

I have heard everyting goes through the turn signal switch. Do I need to replace that?

Thanks.
__________________
It doesn't have nitrous. It has cubic inches.
gotyorgoat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-17-2013, 08:30 PM   #2 (permalink)
 
Instg8ter's Avatar
 
Join Date: Sep 2010
Location: Near Detroit
Posts: 3,724
My Photos: (0)
check that the contacts on the fuse is not rusted, had same problem with mine and it was the ears on the fuse clips. The sockets are self grounding to the taillight housings so make sure all contact points (grounds) are clean also. Yes the wiring runs through the horseshoe harness in the column, thats the next thing to check.
Instg8ter is online now   Reply With Quote
Old 02-18-2013, 09:58 PM   #3 (permalink)
 
gotyorgoat's Avatar
 
Join Date: Jun 2011
Location: Denver
Posts: 104
My Photos: (0)
Thanks Brian. I did sand down the contacts at the fuse panel last time that I tried to troubleshoot this problem. I guess that I have some more digging to do. I finally got the trunk pan put back together and the tail panel welded in so I am itching to take it for a drive but am pretty much limited to the neighborhood until I get the tail lights working.
__________________
It doesn't have nitrous. It has cubic inches.
gotyorgoat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac GTO > 1964-1974 GTO General Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interior lights stop working 02r1 Interior Discussions 13 06-12-2013 06:37 PM
Fog lights not working? bartelt05gto 2004-2006 GTO General Discussion 5 08-19-2011 11:17 AM
Brake lights stopped working kermit2136 1964-1974 Tempest, LeMans & GTO Technical Discussions 6 01-17-2010 07:30 PM
'66 Gto Middle Tail Lights Not Working take5 1964-1974 Tempest, LeMans & GTO Technical Discussions 1 01-03-2010 01:12 PM
head lights quit working on my 66 nmiller5000 1964-1974 Tempest, LeMans & GTO Technical Discussions 11 12-08-2009 02:54 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:44 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.