Brake lights not working - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-17-2013, 07:31 PM Thread Starter
 
gotyorgoat's Avatar
 
Join Date: Jun 2011
Location: Denver
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Brake lights not working

My turn signals work fine, but my brake lights are not working. I have tested the continuity across the switch at the petal and it seems to be working fine. I have also looked at the fuses which seem to be fine.

Does anybody have any advice on this? If it were a grounding problem, the turn signals wouldn't work either, correct?

I have heard everyting goes through the turn signal switch. Do I need to replace that?

Thanks.

It doesn't have nitrous. It has cubic inches.
gotyorgoat is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-17-2013, 09:30 PM
 
Instg8ter's Avatar
 
Join Date: Sep 2010
Location: Near Detroit
Posts: 3,791
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
check that the contacts on the fuse is not rusted, had same problem with mine and it was the ears on the fuse clips. The sockets are self grounding to the taillight housings so make sure all contact points (grounds) are clean also. Yes the wiring runs through the horseshoe harness in the column, thats the next thing to check.
Instg8ter is offline  
post #3 of 3 (permalink) Old 02-18-2013, 10:58 PM Thread Starter
 
gotyorgoat's Avatar
 
Join Date: Jun 2011
Location: Denver
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks Brian. I did sand down the contacts at the fuse panel last time that I tried to troubleshoot this problem. I guess that I have some more digging to do. I finally got the trunk pan put back together and the tail panel welded in so I am itching to take it for a drive but am pretty much limited to the neighborhood until I get the tail lights working.

It doesn't have nitrous. It has cubic inches.
gotyorgoat is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac Tempest, Lemans & GTO > 1964-1974 Tempest, Lemans & GTO Exhaust, Suspension, Alignment, Fuel Tank and Brakes.

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
interior lights stop working 02r1 Interior Discussions 13 06-12-2013 07:37 PM
Fog lights not working? bartelt05gto 2004-2006 GTO General Discussion 5 08-19-2011 12:17 PM
Brake lights stopped working kermit2136 1964-1974 Tempest, Lemans & GTO Exhaust, Suspension, Alignment, Fuel Tank and Brakes. 6 01-17-2010 08:30 PM
'66 Gto Middle Tail Lights Not Working take5 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 1 01-03-2010 02:12 PM
head lights quit working on my 66 nmiller5000 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 11 12-08-2009 03:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome