P0300 Random Misfire issue - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-26-2012, 10:16 PM Thread Starter
 
Join Date: May 2011
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
P0300 Random Misfire issue

Hello everyone,

I have a LS1 GTO cat delete that is having some serious misfire issues. The check engine light flashes at 2000 to 4000 rpm, the light stays on at idle (rough idle) and no misfires over 4000 revolution. I check the wiring and nothing seems to be out of order and tried to detect which cylinder is misfiring but it's every one of the cylinder misfiring at random!

background: 04 LS1 GTO 62k miles. The car has headers, straight pipes, cat delete with diablosport O2off Tune. 3" Full exhaust with 2 32" resonators and mufflers.

I have recently started putting premium Costco gas in the car. My friend who gets gas from the same spot is having fuel related issues. He drives an integra GSR . Not sure if this is a coincidence or it is bad costco gas causing this.

I stopped by Autozone and put a whole thing of fuel injector cleaner and octane boost with hydration eliminator in the car and drove it home for 10 miles. It didn't drive any better!

The car sounds and drives like a tractor and I dont wanna damage anything so you help is definitely appreciated.
Alireza is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-31-2012, 09:43 PM
 
B-ville Goat's Avatar
 
Join Date: Oct 2008
Posts: 319
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Pull the plugs and check them. Also try filling at a different station to see if that helps?

Vice President
Susquehanna Valley GTOs
B-ville Goat is offline  
post #3 of 4 (permalink) Old 01-01-2013, 08:44 AM
 
HP11's Avatar
 
Join Date: Apr 2009
Location: San Bernardino, Ca.
Posts: 2,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
A good reason not to use fuel additives. You'll probably need to burn those additives out of your fuel system and then run a tank or two of gas from the 'different station' before you could rule out the gas itself being the problem.

2005 Pontaic GTO - CGM 6 Speed (My car)
2004 Ford Ranger Edge Supercab (My daily driver)
2010 Mercedes Benz C300 Sedan (Wife's car)
2014 Kia Rio LX (Wife's daily driver)
HP11 is online now  
post #4 of 4 (permalink) Old 01-03-2013, 08:15 AM
 
Join Date: Aug 2011
Location: Spring Hill, TN
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Make sure there is no clog in airflow either, recently seen issues of MAF or just clogs causing not enough air and misfirings happen bad at idle but as the vehicle was higher rev was fine.
Jeffcarr is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
P0300 code taz4141 2004-2006 GTO General Discussion 6 05-11-2012 10:12 PM
Misfire at idle really bugging me Gtojustin Service, Maintenance and Technical Discussion 4 04-04-2012 08:51 PM
random misfire trouble code ? help Bossin Service, Maintenance and Technical Discussion 10 09-25-2011 05:53 PM
06 gto misfire s10ss Service, Maintenance and Technical Discussion 9 01-04-2011 08:48 PM
Gto Misfire KennedyKustoms Engine Discussions 6 04-21-2010 12:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome