Initial Start Up Problems - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-23-2018, 09:52 AM Thread Starter
 
Join Date: May 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Initial Start Up Problems

Just got my 1966 GTO with a 455ci bored .030 over, pro-charger (8lbs boost) put back together. I have a demon GT 750 carb. Tried the initial start up on it and "wants" to run but won't stay running. The ignition is from MSD Ready to Run and the coil is as well (Blaster 3) new plugs and the wires are Fire Core Ignition Wires by Rick Gorski. I had a machinist put in -22 pistons, valves cleaned, Mahle Pistons and rings and a Eagle crank. Firing order is correct with the specs. Any assistance? Did a bypass for the coil as well to help push more juice...Thanks MAD DOG In Rineyville, Ky
MAD CAV SCOUT is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > GTO Forum Help > Gtoforum.com Site Help

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
60 degrees of initial advance?? 65Poncho 1964-1974 Tempest, LeMans & GTO Engine Tuning and High Performance 36 04-07-2017 07:51 PM
Initial Timing Setting NEEDLEZ 1964-1974 Tempest, LeMans & GTO Engine Tuning and High Performance 6 07-21-2015 12:43 PM
Cold start problems with rochester quadrajet. Fuel draining out of carb ? dillon14 1964-1974 Tempest, Lemans & GTO General Discussion 8 07-15-2011 10:55 PM
Radio Problems and remote start issues. dcoen21 Service, Maintenance and Technical Discussion 3 09-06-2009 06:48 AM
69 Hard start problems 69Goat4fun 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 0 05-25-2009 12:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome