Battery Trouble - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-17-2012, 11:56 AM Thread Starter
 
Join Date: Dec 2009
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Battery Trouble

Hey guys,

My battery in my 68 GTO keeps running down. I have checked and double checked all my wires. Now my battery will not charge, I put it on a charger then tried to start it, it would turn the motor over about twice and then just click. I pulled my battery off my pickup and it started right up. I have a new alt, voltage reg, and the battery is only 3 months old. It is a Duralast 1000 cranking amp battery, Any ideas?
simmons68 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-17-2012, 03:29 PM
Former Super Moderator
 
Rukee's Avatar
 
Join Date: Feb 2007
Location: South Central Wisconsin
Posts: 9,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Take the battery back to were you bought it and have it tested. It may be dead due to the no charging condition.
With your truck battery in there verify that the charging system is working with a volt meter. Non running battery voltage should be anywhere from 11.5v to 13v. Running it should be more then 14v but I wouldn't want to see it higher then 15v.
Rukee is offline  
post #3 of 7 (permalink) Old 07-18-2012, 08:04 PM
 
Join Date: Oct 2007
Location: Long Island NY
Posts: 4,702
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
In this day and age....just because something is new, dosen't mean it is good......sounds like a defective battery to me....



Eric Animal is offline  
 
post #4 of 7 (permalink) Old 07-19-2012, 04:52 PM
Super Moderator
 
BearGFR's Avatar
 
Join Date: Aug 2008
Location: Springtown, TX
Posts: 5,731
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 122 Post(s)
Garage
The biggest clue is the fact that it won't hold a charge. I think it's toast.

Bear

BearGFR
Springtown, TEXAS
BearGFR is offline  
post #5 of 7 (permalink) Old 07-19-2012, 06:18 PM
 
Join Date: Mar 2012
Location: long island new york
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
changed two duralast in two different cars this year 1 18 months old 1 25 months old one duralast five years ago shorted out without warning and my tahoe could not even be jumped had to get new battery to start
tony g is offline  
post #6 of 7 (permalink) Old 07-19-2012, 10:29 PM
 
Join Date: Oct 2007
Location: Long Island NY
Posts: 4,702
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Try an Interstate, or a Deka.....



Eric Animal is offline  
post #7 of 7 (permalink) Old 07-20-2012, 06:06 AM
Super Moderator
 
GTO JUDGE's Avatar
 
Join Date: May 2005
Location: Lancaster, PA
Posts: 8,433
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Stated this a few times:

I am a proponent of Declo premium batteries. Only because of nearly 40 years of never being let down. 5 vehicles of mine have one. Bought a 1988 4Runner new in '88. Factory battery lasted 3 years. Delco premium installed in 1991. It was just replaced 3 weeks ago. Not bad for a 7 year battery and it sat for 9 months at a time in cold and hot weather. Some battrery tending when it needed it is all it got.

Everyone has their own preference mine is Delco. Put one in my '70 GTO as well... its the only battery I buy.

President: GTO Association of America
www.gtoaa.org


GTO JUDGE is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac Tempest, Lemans & GTO > 1964-1974 Tempest, Lemans & GTO General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Car trouble newtols2 2004-2006 GTO General Discussion 0 06-04-2011 10:10 AM
When your battery was dead, did your battery light stay on? SueY816 2004-2006 GTO General Discussion 7 05-31-2010 05:54 PM
Does anyone else have trouble with .... ramairthree 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 5 04-21-2009 09:09 PM
gto trouble. crazy8ray 2004-2006 GTO General Discussion 20 06-10-2008 11:29 AM
Trouble with my 05 BigDog Service, Maintenance and Technical Discussion 9 04-26-2005 03:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome