Electrical probs 70 GTO - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-13-2011, 04:19 PM Thread Starter
 
Join Date: Oct 2011
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Electrical probs 70 GTO

I am having electrical trouble with recently purchased and restored 1970 GTO

I dont know much about electrical.

No power to: Gas gauge, instrument lights, blower motor

I replaced fuse to blower with no results.

Any help appreciated?
GTOmaine is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-13-2011, 05:40 PM
 
Join Date: Dec 2010
Location: Warren, Ohio
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Did you check the dash fuses in the fuse box? I think there is one labeled instrument panel, or something close.
Do you have and/or know how to use a dvm? (digital volt meter)
Russ
russosborne is offline  
post #3 of 7 (permalink) Old 10-14-2011, 12:10 PM
 
Join Date: Mar 2011
Location: Texas
Posts: 704
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
electrical trouble 1970 GTO
No power to: Gas gauge, instrument lights, blower motor

none of these circuits are in common with one another. Doubt if you know there is no power to gas gauge. Gauge not working is not a power issue usually. Dash? lights or do you mean instrument idiot? lights? Dash are usually ground issues. Blower motor varies if AC or non AC. Look in factory service manual for first hand info. Best source of detail. Then from there can better answer any questions. Need more detail on each item.
pontiac is offline  
 
post #4 of 7 (permalink) Old 11-20-2011, 12:06 AM Thread Starter
 
Join Date: Oct 2011
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I did replace all fuses.

Gas gauge read FULL all the time,

Instrument lights all 3 pods are out.

The car does have AC
GTOmaine is offline  
post #5 of 7 (permalink) Old 11-20-2011, 12:09 AM Thread Starter
 
Join Date: Oct 2011
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by pontiac View Post
electrical trouble 1970 GTO
No power to: Gas gauge, instrument lights, blower motor

none of these circuits are in common with one another. Doubt if you know there is no power to gas gauge. Gauge not working is not a power issue usually. Dash? lights or do you mean instrument idiot? lights? Dash are usually ground issues. Blower motor varies if AC or non AC. Look in factory service manual for first hand info. Best source of detail. Then from there can better answer any questions. Need more detail on each item.
Not idiot, illumination for guages out
GTOmaine is offline  
post #6 of 7 (permalink) Old 11-20-2011, 01:37 PM
Administrator
 
05GTO's Avatar
 
Join Date: Oct 2004
Location: Deliverance, GA
Posts: 5,132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
The gas gauge problem may be a missing ground wire from the sending unit on the tank to the chassis. Try grounding the wire at the tank that goes to the gauge and see if it changes the fuel level indicator.

Randy


05GTO is offline  
post #7 of 7 (permalink) Old 11-21-2011, 03:26 PM
 
Join Date: Feb 2011
Location: Des Moines, IA
Posts: 662
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
With regard to the dash lights... did you turn the headlight switch counter clockwise? Just checking.

Matthew is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac Tempest, Lemans & GTO > 1964-1974 Tempest, Lemans & GTO General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another electrical ????? 68gtohawk8369 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 19 08-22-2011 04:56 PM
Electrical Issue ty367050 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 4 10-21-2010 03:27 PM
Spent the night at the track and having probs taylorb765 Drive train, suspension, alignment and brakes. 9 10-01-2010 10:52 PM
Run the motor with no electrical? JoeKramer 1964-1974 Tempest, Lemans & GTO Complete Engine Compartment Discussion 1 11-25-2009 08:23 AM
Clutch Probs? Aftermarket? BlownGTO Drive train, suspension, alignment and brakes. 8 02-17-2006 08:00 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome