oil pressure - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-24-2014, 11:30 AM Thread Starter
 
maktope's Avatar
 
Join Date: May 2013
Location: San Pedro
Posts: 210
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
oil pressure

as from previous posts i have been running into problems here and there with some repairs. Before we started repairs my oil pressure read about 65psi at idle and pegged out at 80psi under load. Now since rear seal repair, its pegged out at idle. This seems high to me after reading other posts of oil pressure on here. How do i go about verifiing the pressure. We test drove it yesterday, about a 1/2 hour of up and down hills and holding rpm across the band, no leaks and car runs good.
maktope is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac Tempest, Lemans & GTO > 1964-1974 Tempest, Lemans & GTO General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure BatmanGTO 1964-1974 Tempest, Lemans & GTO General Discussion 20 08-12-2013 09:45 PM
Oil Pressure Metallifan Engine Discussions 3 08-05-2013 06:57 PM
20 psi oil pressure? mbergin 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 15 07-03-2013 04:03 PM
Low oil pressure/oil light coming on etewald 1964-1974 Tempest, Lemans & GTO General Discussion 8 01-26-2013 08:16 PM
no oil pressure wingnutooa 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 19 02-14-2009 01:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome