Turn signals - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 08-01-2012, 06:42 PM Thread Starter
 
joesweeting's Avatar
 
Join Date: May 2011
Location: Virginia Beach
Posts: 256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Turn signals

My turn signals do not work, when I step on the brakes both turn signal lights light up on my dash and on the front of the car (I can see the turn signals in the reflection of the vehicle in front of me) Iím assuming it is a relay. Brake lights and tail lights work fine. Any previous experience with this issue would be greatly appreciated.
joesweeting is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 08-01-2012, 08:19 PM
 
Join Date: Mar 2011
Location: Texas
Posts: 704
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
no relay involved. check your wiring diagram. it is the turn signal switch. not grounds or connector since brake and tail lights work.

Last edited by pontiac; 08-04-2012 at 02:25 AM.
pontiac is offline  
post #3 of 9 (permalink) Old 08-01-2012, 09:07 PM Thread Starter
 
joesweeting's Avatar
 
Join Date: May 2011
Location: Virginia Beach
Posts: 256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks for the information. My tech manual is in the garage I use to work on my car. I will look into switch, I believe this should be the correct one(using google)

http://m.autopartswarehouse.com/deta...QACD6251D.html

Thanks,


Sent from my DROIDX using AutoGuide.Com Free App
joesweeting is offline  
 
post #4 of 9 (permalink) Old 08-02-2012, 04:19 PM
64-67 Expert
 
geeteeohguy's Avatar
 
Join Date: Feb 2008
Location: Fresno, California
Posts: 8,491
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 103 Post(s)
Also, check the connections at the large horseshoe plug under the steering column. They can back out and get loose, and give you issues as well. BTDT.....
geeteeohguy is online now  
post #5 of 9 (permalink) Old 08-02-2012, 05:57 PM Thread Starter
 
joesweeting's Avatar
 
Join Date: May 2011
Location: Virginia Beach
Posts: 256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Will do, thanks for the information

Sent from my DROIDX using AutoGuide.Com Free App
joesweeting is offline  
post #6 of 9 (permalink) Old 08-03-2012, 02:38 PM
 
Join Date: Dec 2011
Location: Duluth, MN
Posts: 85
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Also, check the ground wires on the taillight assemblies themselves. I just had to replace them yesterday because mine weren't working. The ground wires were old and had a bad connection.
etewald is offline  
post #7 of 9 (permalink) Old 08-04-2012, 10:44 AM
 
Join Date: Oct 2007
Location: Long Island NY
Posts: 4,702
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage
Check ALL the bulbs for blow outs, then check BOTH flasher units....FIRST check the fuses......................go from there.



Eric Animal is offline  
post #8 of 9 (permalink) Old 08-10-2012, 07:47 PM Thread Starter
 
joesweeting's Avatar
 
Join Date: May 2011
Location: Virginia Beach
Posts: 256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Replaced all bulbs, fuses and flasher fuse. Using a test light , I have power to my turn signal switch but not after. Ordered new switch will be in next week. Will keep informed, thanks for all the input

Sent from my DROIDX using AutoGuide.Com Free App
joesweeting is offline  
post #9 of 9 (permalink) Old 09-22-2012, 07:46 PM Thread Starter
 
joesweeting's Avatar
 
Join Date: May 2011
Location: Virginia Beach
Posts: 256
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Replaced switch, turn signals work!! sorta they won't turn off after turn. Also installed aftermarket grant steering wheel. Will investigate when steering wheel removal kit arrives, ETA?? Been waiting over 2 months, called year one and was told it will be at least another 2 months. Thanks for everyones input

Sent from my ADR6425LVW using AutoGuide.Com Free App
joesweeting is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac Tempest, Lemans & GTO > 1964-1974 Tempest, Lemans & GTO General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signals Topkat 1964-1974 Tempest, Lemans & GTO General Discussion 14 07-13-2011 08:21 AM
turn signals Topkat 1964-1974 Tempest, Lemans & GTO General Discussion 8 05-14-2011 03:42 PM
'68 turn signals 68greengoat 1964-1974 Tempest, Lemans & GTO General Discussion 3 05-05-2011 09:18 PM
front turn signals Topkat 1964-1974 Tempest, Lemans & GTO General Discussion 3 04-25-2011 07:28 PM
help with turn signals HoldenGTO Service, Maintenance and Technical Discussion 4 01-19-2006 06:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome