Another run that makes me feel slow. - Pontiac GTO Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 09-21-2005, 04:52 PM Thread Starter
 
Join Date: Aug 2005
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Another run that makes me feel slow.

Well I had a chance to run my friends dad's '99 lightning yesterday and once again I am wondering why it feels so slow. I only pulled a car on him from a 20mph-100mph punch. Only a car and a half from a dig. I also fried my clutch on the last run. But still, I was BARELY pulling this thing and it is very close to stock. All it has is a fliter and mufflers, I was expecting at least 3-4 cars.
RevnR6 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-21-2005, 05:25 PM
Administrator
 
05GTO's Avatar
 
Join Date: Oct 2004
Location: Deliverance, GA
Posts: 5,142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
I believe that truck is rated at 360 hp and 440 ft. lbs torque, 0-60 time is 5.4,

Good kill!

Randy


05GTO is online now  
post #3 of 13 (permalink) Old 09-21-2005, 05:31 PM
 
Join Date: May 2005
Posts: 937
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by RevnR6
Well I had a chance to run my friends dad's '99 lightning yesterday and once again I am wondering why it feels so slow. I only pulled a car on him from a 20mph-100mph punch. Only a car and a half from a dig. I also fried my clutch on the last run. But still, I was BARELY pulling this thing and it is very close to stock. All it has is a fliter and mufflers, I was expecting at least 3-4 cars.
Those lightnings are no slouches, I dont think you did bad. They are weakest from the dig because of their problem hooking up. From a roll of 20 the S/C is crankin and they are already hooked. You did fine. You fried your clutch? As in it is dead? Yoru car is brand new with no mods? You must be slippin the hell out of it.
JMVorbeck is offline  
 
post #4 of 13 (permalink) Old 09-21-2005, 07:11 PM Thread Starter
 
Join Date: Aug 2005
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ohh its ok now, it just didn't hook at all for that one race. Just slipped to all hell with it let all the way out. Smelled like clutch for a LONG time. I ran it from a couple of stop lights today and it is doing fine though. Ohh well, I have the factory warranty and an aftermarket warranty that should cover it if it goes bad anytime soon. Plus I have a shop that will hook me up.
RevnR6 is offline  
post #5 of 13 (permalink) Old 09-21-2005, 10:59 PM
 
Join Date: Sep 2005
Posts: 556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I've run a Lightning from a roll and a dig in my T/A (stock). I did better from a roll, and slowly pulled it. From a dig, He inched ahead, due to me spinning, then held about 3/4 length through 3rd. I think you did fine.
Good 2 go is offline  
post #6 of 13 (permalink) Old 09-22-2005, 12:01 PM
 
Join Date: May 2005
Posts: 937
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by RevnR6
Ohh its ok now, it just didn't hook at all for that one race. Just slipped to all hell with it let all the way out. Smelled like clutch for a LONG time. I ran it from a couple of stop lights today and it is doing fine though. Ohh well, I have the factory warranty and an aftermarket warranty that should cover it if it goes bad anytime soon. Plus I have a shop that will hook me up.
Damn, that thing must have been glowing red! BTW, your manufacturer warranty wont cover a clutch, unfortunatly. They are like brake pads, a wear item not normally covered.
JMVorbeck is offline  
post #7 of 13 (permalink) Old 09-22-2005, 05:05 PM Thread Starter
 
Join Date: Aug 2005
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by JMVorbeck
Damn, that thing must have been glowing red! BTW, your manufacturer warranty wont cover a clutch, unfortunatly. They are like brake pads, a wear item not normally covered.
The aftermarket should, especially since i have a hook up at a warranty shop here.
RevnR6 is offline  
post #8 of 13 (permalink) Old 09-22-2005, 05:27 PM
 
BlueTiger's Avatar
 
Join Date: Jan 2005
Location: Hope Mills, NC
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by RevnR6
Well I had a chance to run my friends dad's '99 lightning yesterday and once again I am wondering why it feels so slow. I only pulled a car on him from a 20mph-100mph punch. Only a car and a half from a dig. I also fried my clutch on the last run. But still, I was BARELY pulling this thing and it is very close to stock. All it has is a fliter and mufflers, I was expecting at least 3-4 cars.
You did just fine, a Ford lightning is nothing to frown at. They are beasts.

2004 Pontiac GTO Impulse Blue M6
Custom Tune by RunninWithTheDevil
304 rwhp 335 rwtq
BlueTiger is offline  
post #9 of 13 (permalink) Old 09-26-2005, 06:37 PM
 
Join Date: Mar 2005
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
-RevnR6, How many miles do you have on your car?
Capo is offline  
post #10 of 13 (permalink) Old 09-26-2005, 07:41 PM Thread Starter
 
Join Date: Aug 2005
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
8,500 now. I drive a lot.
RevnR6 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > Off Topic Discussions > Racing and Kill Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome