Tripower on a 67 automatic idle,timing issue - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-02-2017, 07:55 AM Thread Starter
 
Join Date: Jan 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Tripower on a 67 automatic idle,timing issue

Hello all and Happy New Year . I'm new to the forum and my problem is I rebuilt my 66 tripower using Mike Wasson's Pontiac site and installed it on my 67 automatic,now I can't get idle below 1000. Original vac source was from the Qjet on the center of ventori,not direct manifold vacuum. Traced out possible vac leaks,and found when I clamp off advance hose idle drops? Any body been down this road before,or am I missing something here,possibly dist should be getting ventori vac to work properly and pulling up idle? Any help ,direction is greatly appreciated
eurojeff is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-02-2017, 11:53 AM
 
Frank R's Avatar
 
Join Date: Nov 2016
Location: Connecticut/ Ormond Beach FL
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Make sure the end carburetors are closed completely. Put your hand over their throats, you shouldn't feel any suction. Distributor advance needs to be hooked to a ported vacuum source. Clamping off the vacuum advance should make the idle drop.
Frank R is offline  
post #3 of 3 (permalink) Old 01-07-2017, 01:51 PM
64-67 Expert
 
geeteeohguy's Avatar
 
Join Date: Feb 2008
Location: Fresno, California
Posts: 8,470
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 98 Post(s)
X2 on making sure the outer carbs are all the way closed at idle. All Pontiacs of this era ran manifold vacuum to the distributor, not ported. Ran a '66 tripower on my '67 for a few years (also a TH400 car) and it ran extremely well. Good luck.
geeteeohguy is online now  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 1964-1974 Pontiac Tempest, Lemans & GTO > 1964-1974 Tempest, LeMans & GTO Engine Tuning and High Performance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing jumps around at idle Bensjammin66 1964-1974 Tempest, LeMans & GTO Engine Tuning and High Performance 15 10-28-2016 11:01 PM
66 389 tripower timing noluck 1964-1974 Tempest, LeMans & GTO Engine Tuning and High Performance 7 10-27-2016 05:35 PM
Idle and timing gtoearl 1964-1974 Tempest, LeMans & GTO Engine Tuning and High Performance 6 10-31-2015 12:34 PM
Tripower idling issue bowdown232 1964-1974 Tempest, Lemans & GTO Complete Engine Compartment Discussion 7 11-06-2014 09:03 AM
Fast Idle Issue daveh70 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 8 08-23-2009 09:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome