Nasa @ Road America Open Track Aug 4-5 - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-28-2007, 02:55 PM Thread Starter
 
Racer X's Avatar
 
Join Date: Jul 2007
Location: Out on the track.
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nasa @ Road America Open Track Aug 4-5

Road America is in Elkhart Lake, WI.
http://www.roadamerica.com/

Sign up with NASA $40 per year.
http://www.nasaproracing.com/aboutnasa/index.html
We're in the Midwest region. Novices sign up in HPDE 1 and get 1 on 1 with an instructor. Come out and have fun with your car, spectators welcome too. If you only attend 1 track event this year, this is the track to go to. 130+
MPH down the front straight. We'll be at Road America August 4th & 5th. Stop by and say hi. Red 04 GTO #157. I'll post up some pics after the event. See ya on the track.

Last edited by Racer X; 07-28-2007 at 03:11 PM.
Racer X is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > Clubs, Events & Regional Discussion > Great Lakes

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome