04 gto wont heat up - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-05-2019, 11:31 AM Thread Starter
 
Join Date: Jan 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
04 gto wont heat up

The needle will jump up a few ticks when driving in the city (stop and go) the heater will also be somewhat hot. When it's on the highway it'll cool all the way back down and the heater then blows cold. Changed the t-stat and housing today and tested the old t-stat it opened at about 190*...what gives?
Captn_Cook is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-05-2019, 12:40 PM
 
RMTZ67's Avatar
 
Join Date: Mar 2011
Location: Albuquerque N.M
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
Garage
Quote:
Originally Posted by Captn_Cook View Post
The needle will jump up a few ticks when driving in the city (stop and go) the heater will also be somewhat hot. When it's on the highway it'll cool all the way back down and the heater then blows cold. Changed the t-stat and housing today and tested the old t-stat it opened at about 190*...what gives?
I take it the radiator or bottle is full/filled?
RMTZ67 is online now  
post #3 of 5 (permalink) Old 01-05-2019, 05:20 PM
 
GTO44's Avatar
 
Join Date: Apr 2016
Posts: 320
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Are your fans running all the time? They shouldnt come on until the car heats up

2006 GTO M6

Motor - Stock with Vararam
Bunch of suspension
Bunch of brakes
Stock tune

365/368 std
12.81 @ 110.6 2.03 60'
GTO44 is online now  
 
post #4 of 5 (permalink) Old 01-05-2019, 05:23 PM Thread Starter
 
Join Date: Jan 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I'd believe so, never seen the coolant level in the reservoir change. Hard to be for sure without a rad cap lol
Captn_Cook is offline  
post #5 of 5 (permalink) Old 01-05-2019, 09:02 PM Thread Starter
 
Join Date: Jan 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Basically i'm an idiot i reckon. Used the "secret" coolant temp on the menu and it got to 190 and dropped and went back blah blah. While the manual gauge only jumped up a few ticks. (this is going to annoy me to no end but whatever i guess) The heater could still be hotter, heater core?
Captn_Cook is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Motor wont run well went vacuum advance is hook up trainman115 1964-1974 Tempest, Lemans & GTO General Discussion 3 09-23-2016 08:25 PM
04 gto wont start!! Joey0229 2004-2006 GTO General Discussion 5 11-23-2013 05:58 AM
ran over a deep puddle and gto puttered and wont start up batmans Service, Maintenance and Technical Discussion 13 01-08-2011 09:27 AM
Flowmaster Super 44's Wont fit on a 04 GTO??? AmeliaGoat Intake and Exhaust Discussions 8 11-05-2010 05:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome