2005 GTO high beams dont work - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-12-2012, 06:23 PM Thread Starter
 
Join Date: Apr 2009
Location: Richmond Indiana
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2005 GTO high beams dont work

HELP !!!

My high beams dont work after I took the car out of storage this summer. I can push the lever in on the steering column and the blue high beam instrument light comes on so I know that the switch is good. I removed the relay and replaced it with a new one under the hood. Is there a relay for high beams under the dash?? Or is there something else that I am missing. When I turn on the high beams I can hear a click from the relay / fuse box under the hood. Not sure if this is normal?
Edzjk is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yellow high-beams on '70 GTO... see pics ZGstar 1964-1974 Tempest, Lemans & GTO General Discussion 2 11-23-2011 09:45 PM
Why dont both my fog lights work?? wingman04 Exterior Discussions 7 08-13-2011 02:58 PM
Daytime running lights and dash lights dont work!!!!! Vettekid1992 Service, Maintenance and Technical Discussion 1 09-18-2010 10:27 PM
100watt High Beams? AlanSr Exterior Discussions 6 03-28-2009 12:07 AM
HID for high beams? AlanSr Exterior Discussions 3 03-26-2009 04:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome