2006 GTO MAP sensor reads low - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-03-2013, 11:48 AM Thread Starter
 
Join Date: Aug 2013
Location: Pearland,TX
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2006 GTO MAP sensor reads low

My MAP sensor a reads in the 0-15ish range. Instead of showing 100 kpa at prestart, it shows 10 kpa. I tried a new sensor and it did the same thing. Any ideas? I'm about to get Hptuners and want to make sure this resolved first.
Thanks!

Sent from AutoGuide.com Free App

06 Torrid Red Pontiac GTO M6 - 403 Stroker, Varamam, PRC As-Cast 225cc Cathedral Heads, Wiseco# 926-K394X05 Pistons, Manley 11270 Valves, aggressive cam, B&M Sport Shifter, uknown clutch, Kooks LT and Cats, resonators and Corsa Sport.
CharleyT is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-03-2013, 02:24 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
That is very odd seeing your replaced the sensor. It's definitely electronics and nothing caused by the engine. Where are you seeing the data for kPa? If you're using a handhed it may be a glitch in the that.

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
post #3 of 7 (permalink) Old 10-04-2013, 01:19 PM Thread Starter
 
Join Date: Aug 2013
Location: Pearland,TX
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by svede1212 View Post
That is very odd seeing your replaced the sensor. It's definitely electronics and nothing caused by the engine. Where are you seeing the data for kPa? If you're using a handhed it may be a glitch in the that.
Well... I'm an idiot! Yes, reading it on a Diablo Trinity, and I'm reading psi, not Kpa! Sorry about the confusion. And it's reading approx. 14.85psi, when I first turn on the key. And it moves lower with throttle up requests.

But, the system keeps throwing P0106 - MAP/Barometric Pressure Circuit Range/Performance Problem.

Update. Was going to try to run the car in closed loop by disconnecting the throttle body connector. When I do that, the car starts, revs to 800rpm (there abouts), then dies. So now I'm even more stumped. Guess it's time to hit the books (and web) this weekend to see why the thing is acting up.

Last edited by CharleyT; 10-04-2013 at 01:44 PM.
CharleyT is offline  
 
post #4 of 7 (permalink) Old 10-04-2013, 01:51 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
It won't run right with the TB disconnected. If you can switch to kPa as it has more definition. On a car that's not running with the key on the MAP readings should not change with throttle position as there is no air demand on the plenum. It would be nice if when you got HPT you could post a log to see what's going on.

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
post #5 of 7 (permalink) Old 10-04-2013, 02:27 PM Thread Starter
 
Join Date: Aug 2013
Location: Pearland,TX
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by svede1212 View Post
It won't run right with the TB disconnected. If you can switch to kPa as it has more definition. On a car that's not running with the key on the MAP readings should not change with throttle position as there is no air demand on the plenum. It would be nice if when you got HPT you could post a log to see what's going on.
You guys always rock! It doesn't change, until the engine is running. I'll have to see if Diablo has a way to monitor as Kpa and post results if possible.

We're ordering HPT in two weeks. I was trying to clear all the codes before I got it, but sounds like I need it to clear this one up. I'll post a log as soon as we have HPT and can run a test.
CharleyT is offline  
post #6 of 7 (permalink) Old 11-09-2013, 06:58 PM Thread Starter
 
Join Date: Aug 2013
Location: Pearland,TX
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Here comes the Logs! *NOT* Need help. hehe

I started with a tune based on a file from the HPTuner repository. I'm still getting a P0106 MAP/Barometric Pressure Range/Performance DTC, but the car is idling better. The gas mileage has plunged down to 8-12 from 15-18, so I assume the current tune is too rich. I'm still doing a lot of reading to learn what I'm doing. hehe

Not sure how to attach log files, or the tune. It appears those file types are not available for me to upload. Is there a better way to get them on here?
CharleyT is offline  
post #7 of 7 (permalink) Old 11-09-2013, 08:34 PM Thread Starter
 
Join Date: Aug 2013
Location: Pearland,TX
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
And new here's something we hope you really like!

Hey stupid. Why not just share the files via public dropbox links?

I'm a little slow on the uptake sometimes. hehe

Here are links to the files:
Log 1:
https://www.dropbox.com/s/ytsvodr2ew...11092013_1.hpl

Log 2:
https://www.dropbox.com/s/uw916udjb7...11092013_2.hpl

Current HPTuners Tune File
https://www.dropbox.com/s/coy8fhhfw6...oreAdjIdle.hpt

06 Torrid Red Pontiac GTO M6 - 403 Stroker, Varamam, PRC As-Cast 225cc Cathedral Heads, Wiseco# 926-K394X05 Pistons, Manley 11270 Valves, aggressive cam, B&M Sport Shifter, uknown clutch, Kooks LT and Cats, resonators and Corsa Sport.
CharleyT is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 GTO low compression ak gto Engine Discussions 0 05-26-2013 03:32 AM
2006 GTO low mileage value Eric Animal 2004-2006 GTO General Discussion 6 05-02-2011 10:17 AM
MAP sensor problems!!!!!! gtospeed Intake and Exhaust Discussions 11 10-29-2008 07:08 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome