70 GTO Gauges. HELP!!!!! - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-29-2017, 07:34 PM Thread Starter
 
Join Date: Oct 2015
Location: Conway SC
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
70 GTO Gauges. HELP!!!!!

I have a 70 GTO with rally gauges. To make this story short I will not go through all the problems I have had and get to the main problem. I had the gauges out of the
pod and soaked it in vinegar to de-rust it. The gas gauge was bad and I had it rebuilt. The temp gauge worked fine but after putting it all back together the temp gauge pins to HOT as soon as I turn on the key. I have a brand new printed circuit also. Does anyone have a picture of the back of the gauges with the printed circuit off? There are four terminals in the temp gauge and there is an insulator going under three of them. I don't know if I have it on the correct three. PLEASE HELP! I'm going crazy with issues with this dash.
goatoligst is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-30-2017, 12:12 PM
 
Join Date: Jan 2015
Location: Injun Territory, 'Merica!
Posts: 1,611
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 121 Post(s)
Have not personally encountered the pegging hot situation, but sure sounds like an incorrect sending unit problem. Have several sets of original '69-early 70 rally gauges boxed up, will be over tomorrow moving parts. Will try and pull the boxes out, they are in boxes & tubs yet to be moved.
Pinion head is offline  
post #3 of 3 (permalink) Old 07-30-2017, 01:25 PM Thread Starter
 
Join Date: Oct 2015
Location: Conway SC
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It can't be the sending unit. The gauge worked until I took it out and reinstalled it. I didn't touch anything under the hood. I have a feeling I have the insulator in the wrong position. The temp gauge is the only gauge with one. Any help would be appreciated.
goatoligst is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rally Cluster gauges for '67 GTO Goat67 1964-1974 Tempest, Lemans & GTO Convertible Top, Interior, Glass and Trunk 19 05-14-2017 11:13 AM
Tach and gauges for 64 GTO tguggino 1964-1974 Tempest, Lemans & GTO General Discussion 6 01-14-2016 08:25 PM
1969 GTO gauges 69GTOCONVLOVER 1964-1974 Tempest, LeMans & GTO Projects, Barn Finds & Restoration Discussions 10 12-26-2013 08:29 AM
non rally gauges in 70 gto even steven 1964-1974 Tempest, Lemans & GTO Convertible Top, Interior, Glass and Trunk 2 06-28-2009 07:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome