Bad Lifter??? - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-26-2015, 09:01 AM Thread Starter
 
tlrchrls's Avatar
 
Join Date: Apr 2014
Location: Schuylkill Haven, PA
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Bad Lifter???

Alright so the past few weeks have made me start to hate my goat. First the radiator cracked and needed a new one, and then the infamous "clicking, chattering" sound started. Took it to the shop and they said it was the manifold gasket, which they fixed, but the noise continued. Took it back and they said it could be a bad lifter, but for whatever reason they did a fresh oil and filter change and now the noise is gone (for now). So my question is, if it is a bad lifter would changing the oil really help, even if its only temporary?
tlrchrls is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-26-2015, 08:09 PM
 
pocketmaster's Avatar
 
Join Date: Feb 2010
Location: Weatherford, Tx
Posts: 252
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by tlrchrls View Post
Alright so the past few weeks have made me start to hate my goat. First the radiator cracked and needed a new one, and then the infamous "clicking, chattering" sound started. Took it to the shop and they said it was the manifold gasket, which they fixed, but the noise continued. Took it back and they said it could be a bad lifter, but for whatever reason they did a fresh oil and filter change and now the noise is gone (for now). So my question is, if it is a bad lifter would changing the oil really help, even if its only temporary?
Do you have headers or is it the stock manifolds?? I know mine got "noisier" after my header install. Kinda like the sewing machine type chatter, but from what I've read and researched this is normal. Being that it stopped follwing the oil change would lead me to something else.

God Bless Billiards!!!!
pocketmaster is offline  
post #3 of 5 (permalink) Old 03-27-2015, 03:18 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
Lifters usually don't fix themselves. Could the oil have been low maybe? Low oil and/or pressure or debris that got up to the lifter are two main causes short of real failure.

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
 
post #4 of 5 (permalink) Old 03-27-2015, 07:43 PM
 
pocketmaster's Avatar
 
Join Date: Feb 2010
Location: Weatherford, Tx
Posts: 252
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by svede1212 View Post
Lifters usually don't fix themselves. Could the oil have been low maybe? Low oil and/or pressure or debris that got up to the lifter are two main causes short of real failure.
Funny you say that. I have a motorcycle that had a lifter chattering. After an oil change it stopped. Come to find out there was debri partially obstructing one lifter causing the chatter. Drained the oil and filtered it. Little bits of who knows what were in the oil

God Bless Billiards!!!!
pocketmaster is offline  
post #5 of 5 (permalink) Old 03-29-2015, 09:25 AM Thread Starter
 
tlrchrls's Avatar
 
Join Date: Apr 2014
Location: Schuylkill Haven, PA
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Nope, everything is stock. But good news is, it's been a week since the oil change and so far so good. The shop also said it could have been debris in the oil but seems strange since I change the oil on schedule everytime.
Thanks for the replies and input, definitely some peace of mind.
tlrchrls is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad Lifter! taylorjones_11 Engine Discussions 7 11-24-2014 09:25 AM
Bad Ground? Bad Link? Bad NSW? rock36 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 4 05-27-2014 04:57 AM
noisy lifter... rickm 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 0 09-16-2012 07:57 AM
Will I need new lifter? lasoya113 Engine Discussions 3 05-25-2011 02:16 AM
Finding bad bad vibrations [email protected] 1964-1974 Tempest, Lemans & GTO General Discussion 11 11-25-2008 10:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome