Bad Pedal - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-06-2018, 04:12 PM Thread Starter
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bad Pedal

Anyone know where I can find an accelerator pedal assembly. Iíve had my 2005 to a Chevy Dealer and they said that they are out of stock and not to be restocked. The car currently runs but at time the check engine light will come on and the car will lose acceleration. Eventually the light goes off and the car goes back to normal. However, it is a problem that has to be fixed and the error code is the accelerator. I just can find the part. I have been searching the internet up and down and cannot seem to find a new oem part or even a used one anywhere. Any help would be appreciated.
Nushey is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-14-2018, 02:32 PM Thread Starter
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I just want to reach out again regarding the accelerator assembly. Does anyone know of a fix other than replacing the entire part?
Nushey is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Muncie Reverse Gears. How bad is bad? Layzdude 1964-1974 Tempest, Lemans & GTO Undercarriage, Frame, Transmission and Differential Discussions. 6 02-22-2016 02:53 PM
Bad Ground? Bad Link? Bad NSW? rock36 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 4 05-27-2014 04:57 AM
Bad vibrations steering wheel,gas pedal and center console!!! GTOTX Service, Maintenance and Technical Discussion 3 07-24-2011 06:34 PM
Really bad whining/scraping noise when depressing clutch pedal hcpcjj Service, Maintenance and Technical Discussion 4 02-04-2009 12:42 PM
Finding bad bad vibrations [email protected] 1964-1974 Tempest, Lemans & GTO General Discussion 11 11-25-2008 10:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome