Car keeps dying - Pontiac GTO Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 09-16-2014, 01:20 PM Thread Starter
 
Join Date: Apr 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Car keeps dying

My 04 has been revving up to about 2000rpm when I stop at a light then it drops to about 500rpm and goes back to 2000rpm. Sometimes it goes back to idle and sometimes it dies and repeatedly dies after starting again unless I put my foot to the floor and clean it out. I noticed I'm smelling more fuel than normal from the exhaust. I'm thinking I have one maybe more injectors that are sticking open and causing it to load up and die. Wanted to see what everyone else thought before I go out and buy a new set of injectors. Thanks


Sent from AutoGuide.com Free App
04black is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-16-2014, 03:03 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
O2s would be more likely. Is the engine modified in any way?

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
post #3 of 13 (permalink) Old 09-16-2014, 04:12 PM Thread Starter
 
Join Date: Apr 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ms3 cam, kooks LTs, fast 92 intake and throttle body. Also has no cats


Sent from AutoGuide.com Free App
04black is offline  
 
post #4 of 13 (permalink) Old 09-16-2014, 04:13 PM Thread Starter
 
Join Date: Apr 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I can post a video of what it's doing once I get off work


Sent from AutoGuide.com Free App
04black is offline  
post #5 of 13 (permalink) Old 09-16-2014, 09:44 PM Thread Starter
 
Join Date: Apr 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
how do you put a video on here?
04black is offline  
post #6 of 13 (permalink) Old 09-17-2014, 08:19 AM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
For the vid upload it to Youtube and copy the link here. Off hand it sounds like the tune more than anything. A decent sized cam like the MS3 takes some careful tuning. My old cam did a similar thing and I ended up having to tune it for open loop as from cam reversion it would go crazy rich at idle and would surge just like yours is doing.

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
post #7 of 13 (permalink) Old 09-17-2014, 01:18 PM Thread Starter
 
Join Date: Apr 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had retuned after I put I had to replace the engine and cam. It had the ms3 in before so that's what I put back in it and when I had retuned it was running fine. It didn't start doing that until 5 or 6 months after the retune


Sent from AutoGuide.com Free App
04black is offline  
post #8 of 13 (permalink) Old 09-17-2014, 07:14 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
Could have an air leak or bad MAF or O2s. You should log a scan and see what you see.

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
post #9 of 13 (permalink) Old 09-18-2014, 12:27 PM Thread Starter
 
Join Date: Apr 2011
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would but I don't have anyway to do that. I called my tuner yesterday and I'm waiting on him to call me back. Maybe I can have him log it


Sent from AutoGuide.com Free App
04black is offline  
post #10 of 13 (permalink) Old 09-18-2014, 01:22 PM
 
BWinc's Avatar
 
Join Date: Sep 2005
Location: Lee's Summit, MO
Posts: 457
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'd almost think that bad O2s would throw a CEL.

Current: MGW-p, H-pipe, SS OTRCAI, Lovell rear springs, Eliminator shocks and Pioneer AVH-P3300BT, JBA LTs+catless mids, Drilled/Slotted rotors, Kooks Afterburners, catch can & Tune Next: ??? Wish list: Intake & TB, modest cam, UDP, gears
BWinc is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
06 Goat Battery Keeps Dying JohnnyGTO6 Service, Maintenance and Technical Discussion 4 05-22-2014 08:23 PM
DC/MD/NOVA - Please help my dying mother! saintz 1964-1974 Tempest, Lemans & GTO General Discussion 0 03-03-2011 08:38 PM
69 GTO dying when hot Flyboy 1964-1974 Tempest, Lemans & GTO General Discussion 45 08-18-2010 12:43 PM
Dearborn 41st ANNUAL F.M.R.C. CAR SHOW & CAR CORRAL Hi Speed Great Lakes 0 07-19-2010 05:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome