check oil level, WTF - Pontiac GTO Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 01-21-2008, 07:08 PM Thread Starter
 
Join Date: Feb 2006
Posts: 337
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
check oil level, WTF

Ok, this is getting on my last nerve, followed a Corvette into a hairpin curve, nailed it, check oil level light comes on.
Pull over next stop, oil full. Get back in, get on interstate, hammer it, check oil level.....................................ok, checked it again, FULL.
Let car sit all day, hop in, turn the key, pull out on the street, wind 2nd, check oil level. Ok, check it when I get home this time, oil ok.

Take "check oil check" to dealer, dealer looks at it, of course, it doesn't come on idling, changes oil, runs codes, "no code" say's drive it must be weather. (?) Get in jump on highway, wind 3rd, CHECK OIL LEVEL!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!FOR NEXT 2 MILES......
Ok, why the hey do I get this warning everytime I nail it? Just started at 34K. Anyone having this problem? (Why the hell didn't they just put the oil pressure gage in?) This is the first malfunction except for the buttery shifter I ripped out.....
aintmisbehavinn is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 01-21-2008, 09:59 PM
 
Devils3023's Avatar
 
Join Date: May 2007
Location: wayne, nj
Posts: 227
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Devils3023
Sounds like the oil level sensor is acting up. When you mash the throttle the oil gets sloshed to the back of the pan temporarily and w/ a faulty sensor could be enough to trip the warning light. Try to get to the dealer with the light on still and let them see it, or try taking it to another dealer.
Devils3023 is offline  
post #3 of 15 (permalink) Old 01-22-2008, 07:10 AM
Former Super Moderator
 
Rukee's Avatar
 
Join Date: Feb 2007
Location: South Central Wisconsin
Posts: 9,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Take the service writer for a ride so he can see the light on and verify the problem.
Rukee is offline  
 
post #4 of 15 (permalink) Old 01-22-2008, 07:35 AM
Super Moderator
 
GTO JUDGE's Avatar
 
Join Date: May 2005
Location: Lancaster, PA
Posts: 8,433
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Must be the weather???!!???
Car have arthritis? .....
Lame, just lame...

Oil sensor, or oil sending unit?

President: GTO Association of America
www.gtoaa.org


GTO JUDGE is offline  
post #5 of 15 (permalink) Old 01-23-2008, 05:36 PM Thread Starter
 
Join Date: Feb 2006
Posts: 337
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Actually went off twice since the last post, only came on when I nailed it. Got to be the sensor (I hope, motor sounds like a sewing machine, no abnormal ticks, knocks or clicks.) Going back to the dealer and give the service boy a ride....(maybe one he won't forget and regret...)
aintmisbehavinn is offline  
post #6 of 15 (permalink) Old 01-24-2008, 02:45 PM
 
Join Date: Jan 2008
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sorry to hop in your thread, OP!! i have the same problem except flooring it. it pop on every time i start the engine... oil level high!! no oil leak!! my question is, is there a way to reset this? i tried hitting the mode button, but like i said it comes on every time i start the engine

FYI: i changed the oil about 3 weeks ago and this problem recently happen

Last edited by 50DEUCE; 01-24-2008 at 02:55 PM.
50DEUCE is offline  
post #7 of 15 (permalink) Old 01-25-2008, 11:01 AM
 
Join Date: Jan 2008
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
NVM!! found out how to reset the check oil light!!
50DEUCE is offline  
post #8 of 15 (permalink) Old 02-03-2008, 08:33 PM Thread Starter
 
Join Date: Feb 2006
Posts: 337
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Found out there is a small switch behind the block that "was made in Japan". (?) Switch went south, dealer replaced, no more false alarms...
aintmisbehavinn is offline  
post #9 of 15 (permalink) Old 01-10-2009, 04:18 PM
 
Join Date: Jan 2009
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hey man can you tell me exacually were the switch behind the block is i am pretty sure i have the exact problem. I have 50k miles so really dont want to have to take it to the dealer ship. Also would you happen to know the part number of the switch or the name of the part whats it called or anything of that sort any help would be great. Thanks
Tprien is offline  
post #10 of 15 (permalink) Old 01-11-2009, 08:31 PM
 
Join Date: Jan 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
is it the light or the display message? If its the display message then turn the key to the "On" position without turning the car on while its doing the system check push the gas in 3 times fairly quickly then turn it to off. then start her up.
Michael.Narlock is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Change Intervals GTO JUDGE Service, Maintenance and Technical Discussion 2 09-30-2007 01:33 AM
Oil Pressure Gauge ACR 2004-2006 GTO General Discussion 7 12-03-2006 11:21 AM
Peak Oil Myth Debunked b_a_betterperson The Lounge 3 11-24-2006 11:01 PM
laugh for the day 170FC The Lounge 6 10-19-2005 12:29 AM
We're Not Running Out Of Oil b_a_betterperson The Lounge 6 08-24-2005 06:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome