ERA CI with SLP MAF - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-31-2005, 04:33 PM Thread Starter
 
Join Date: Oct 2005
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ERA CI with SLP MAF

I had the ERA CI on my car and then purchased a used SLP MAF that came in today. I just got finished installing it and have not been able to test it on the road as yet. I will let you guys know how it does.

Ok after getting everything plugged in it seems to work fine. I will let you know how it drives over the next couple of days.

Last edited by GGTTOO; 12-31-2005 at 08:00 PM.
GGTTOO is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome