header troubles - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-18-2015, 08:56 PM Thread Starter
 
Join Date: Mar 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
header troubles

Just installed eldabroc shorty headers and now car runs rough maf code came up, replaced it still persist replaced plugs and wires still persist any clues?? Also idk if in relation but check oil keeps popping up and going away but oil is just fine btw it's a 2004 gto upgrade are kn air filter and slp cat back exhaust
logan4720 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-19-2015, 06:08 PM
 
Join Date: Oct 2014
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
car runs rough

you need to have a tune done for it all to work.
papousr58 is offline  
post #3 of 3 (permalink) Old 03-19-2015, 06:21 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
Those headers shouldn't make a MAF code come up. Fueling may be a little off but it should not affect idle at all unless you have a pretty big exhaust leak. The K&N may have oiled up the MAF sensor. I would start by making sure you don't have any leaks in the intake path and to carefully spray the MAF sensor with a cleaner made for that.

You'd be best to have a mechanical gauge check of your oil pressure. Just because it has the correct level of oil doesn't mean it is being pumped to minimum pressure. It could also be the oil sending unit is going bad and the mechanical gauge check will verify if it is.

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Troubles need quick help Cole S Service, Maintenance and Technical Discussion 5 06-07-2013 11:11 AM
Hot start troubles Flyboy 1964-1974 Tempest, Lemans & GTO General Discussion 4 06-17-2012 10:44 PM
Brake troubles on a '67...again and again! daveh70 1964-1974 Tempest, Lemans & GTO Exhaust, Suspension, Alignment, Fuel Tank and Brakes. 6 11-09-2009 05:56 PM
Radiator Troubles Tyrrel_goat 2004-2006 GTO General Discussion 8 05-09-2008 12:47 PM
70 GTO starter troubles 70GTOConv 1964-1974 Tempest, Lemans & GTO General Discussion 4 03-06-2005 12:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome