Knock Knock, Who's There? - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-18-2011, 08:13 AM Thread Starter
 
daniel99ta's Avatar
 
Join Date: Nov 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Knock Knock, Who's There?

Gotta love the play on words.
My brother has an 05 GTO LS2 and we had a bit of a Nitrous explosion one day. Needless to say I pulled the heads, checked the pistons, did a valve job and replaced the destroyed intake with a new shiny aluminum one. Can runs and drives like a champ but I have a loud knock in the mornings on a cold start that was never there before. After it warms up it goes away. I have several LS motors over the years (LS1, 3x LS2, and an LS7) and I know they can be loud but this is a bit much. I run 5w30 penzoil which is what I have always ran in this car with no noise until now. Any ideas?
daniel99ta is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-18-2011, 02:26 PM Thread Starter
 
daniel99ta's Avatar
 
Join Date: Nov 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BTW I wish I had a more positive post for my first post, but I was told this would be the place to ask the people with experience.
daniel99ta is offline  
post #3 of 9 (permalink) Old 03-18-2011, 04:31 PM
 
AlaGreyGoat's Avatar
 
Join Date: Jul 2006
Location: Birmingport, Alabama
Posts: 827
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Could have something to the explosion, but I don't know what it could be. Ls motors
with their short piston skirts have piston slap on start up. Wear causes clearance and
more slap. Nitrous, with it high cylinder pressure causes much more wear than normal
and collapse the skirts.
When the pistons heat up and expand, they quieten down.
Most of the good knowledgeable people on the forum don't live here, but
will chime when they get a chance.

Larry

2005 GTO Quick - 1984 Honda V65 Magna Quicker - 2004 Z06 Quickest
AlaGreyGoat is offline  
 
post #4 of 9 (permalink) Old 03-18-2011, 05:44 PM
 
GM4life's Avatar
 
Join Date: Mar 2007
Location: RAF Lakenheath, UK
Posts: 4,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Top end or bottom end of motor? Could have a bad lifter, piston ring, bearing.



GM4life is offline  
post #5 of 9 (permalink) Old 03-18-2011, 05:48 PM Thread Starter
 
daniel99ta's Avatar
 
Join Date: Nov 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks for the info. I only ran 1 and a half bottles through the car with 150 shot and it went from zero noise to pretty loud after the one incident. Car only has about 30,000 miles on it.
daniel99ta is offline  
post #6 of 9 (permalink) Old 03-18-2011, 05:53 PM Thread Starter
 
daniel99ta's Avatar
 
Join Date: Nov 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by GM4life View Post
Top end or bottom end of motor? Could have a bad lifter, piston ring, bearing.
Not real sure sounds kinda in the lifter range but would the explosion affect the lifters in any way?
daniel99ta is offline  
post #7 of 9 (permalink) Old 03-28-2011, 04:38 PM
 
preach's Avatar
 
Join Date: Jan 2010
Location: Sacramento
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to preach
Could this also simply be the "knock in the trunk" that puzzled so many people for so long?

Can't remember the details on it, but I'll look for it.

06 M6 CGM
preach is offline  
post #8 of 9 (permalink) Old 04-02-2011, 04:17 PM
 
Join Date: Apr 2010
Location: Deer Park, Tx
Posts: 259
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
i had some dmg to my cam when i pulled my motor, it was one of those MTI cams made by Comp Cams that didn't harden right... anyways, the hardened part started chipping away from where the roller lifter rolls on it... about 6 lifters did this while it was in service. it made a lot of noise on the top end. honestly it really sounded like super loud injector clicking and grinding.

that is about the extent of my knocking problems.

oh i also had a bad oil press sensor that lead to a spun bearing... that was more like a banging noise
motoristx is offline  
post #9 of 9 (permalink) Old 04-04-2011, 01:34 PM
 
jpalamar's Avatar
 
Join Date: Jul 2008
Location: Boyertown, PA
Posts: 3,765
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
WOuldn't a bad oil pressure sensor throw a CEL?

2003 Corvette Z06 - MGW shifter, Corsa X pipe, Corsa Xtreme exhaust, Texas Speed long tubes w/o cats, PowerStop rotors/pads, Conti DWS tires, C6Z51 F&R sways, C5R headlights, tuned

04 GTO - sold
jpalamar is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
low end knock? cam36 2004-2006 GTO General Discussion 8 03-09-2011 08:03 PM
Engine knock... PisnNapalm 1964-1974 Tempest, Lemans & GTO Complete Engine Compartment Discussion 17 10-08-2010 03:13 PM
slight knock mtullo Drive train, suspension, alignment and brakes. 0 10-23-2006 05:16 PM
Knock 36Goat 2004-2006 GTO General Discussion 4 07-03-2006 10:21 PM
Knock Knock Knock Knock SLVR DOG 2004-2006 GTO General Discussion 6 06-28-2006 08:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome