LS2 Engine noise - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-27-2005, 09:03 AM Thread Starter
 
Join Date: Apr 2005
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
LS2 Engine noise

My LS2 is making a "ticking" noise. Sounds to me like lifters, piston slap or exhaust leak. The dealer is telling me this is normal. It's hard to tell exactly where the noise is coming from. Is anyone else experiencing the same? I have heard that GM engines have this problem and that there are many unhappy people out there.

Last edited by joegoat; 04-27-2005 at 09:53 AM.
joegoat is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-27-2005, 11:55 AM
 
GTOJon's Avatar
 
Join Date: Jan 2005
Location: NJ
Posts: 304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's hard to describe the sound I hear, it's almost like a ticking, but on mine it's the fanbelt spinning.

Jon
'87 Z28 with mods | '05 GTO - Red on Red A4

GTOJon is offline  
post #3 of 4 (permalink) Old 04-27-2005, 12:27 PM
 
Join Date: Jan 2005
Posts: 3,541
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yes, even the LS1 makes the noise as well as the 4.8's,5.3's, and the 6.0's. I work for GM and it used to piss me off every time I started my car and would here it. They said there was nothing you could do for it so I put on my l.t.'s and loudmouth exhaust and it's not nearly as noticeable.....this just happens to be a 1550.00 + solution..
GTODEALER is offline  
 
post #4 of 4 (permalink) Old 04-27-2005, 07:35 PM
 
fergyflyer's Avatar
 
Join Date: Apr 2005
Location: Eustis Fl.
Posts: 3,445
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by joegoat
My LS2 is making a "ticking" noise. Sounds to me like lifters, piston slap or exhaust leak. The dealer is telling me this is normal. It's hard to tell exactly where the noise is coming from. Is anyone else experiencing the same? I have heard that GM engines have this problem and that there are many unhappy people out there.
I've had 2 LS1's that did it,and friends LS1 also does it. This LS2 does it also, but not as bad. My LS6 did not seem to do it though. It's not really a problem, just a different sound than most people are accustomed to hearing.
fergyflyer is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome