P0335, TCS turns off, and crank/no start or start then die. - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-11-2015, 12:09 AM Thread Starter
 
Join Date: Feb 2015
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
P0335, TCS turns off, and crank/no start or start then die.

I have read and read on this and there seems a few people that have had this same problem but nobody comes back to say what fixed their problem.

My 06 6 speed GTO has had issues with starting and then dying immediately or cranking and not starting for a cycle or two.

Problems:

MIL with P0335
TCS goes off and will not turn back on.
cranks and will not start, but will if I cycle key
starts and dies immediately

I have found that if I hit the unlock button on the key fob that It eliminates the starting and then dying problem. Or it at least allows me to fire it right up seconds after it dies. I use to have to wait awhile before it would even crank again when it would do this.

I have also found that when the TCS shuts off at startup that if I restart it and hit the button off and on during startup that it will allow me to keep it on.

I occasionally get a check engine light and every time it says p0335 (crank position sensor). I have checked the wiring and plug ends, I then replaced the sensor and still get random MIL with the same code.

I have yet to try a Relearn with my HPTuner.

It seems if I don't give the car time to run through the systems check when I turn on the key that it will start right up without a check engine light. Could just be a coincidence. The light will go out after a few starts usually.

So I basically can bypass all the problems, but I am sick of it not working right.

Does not seem to effect performance. Was doing this on the dyno with the tuner and still made consistence results. (492-499 rwhp ).

IT had all of these problems before the H/C/I install

Anybody fix this and how? I am hoping a relearn might fix it.
dlb1982 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-13-2015, 09:47 PM Thread Starter
 
Join Date: Feb 2015
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I went and had a case relearn done at a local shop. They said it came up as successful. I still get a (pending) p0335 code upon startup with HP tuners. Is this normal? After I start the car and clear that and check codes its fine. The pending code never has a MIL after its started.
dlb1982 is offline  
post #3 of 3 (permalink) Old 10-13-2015, 09:57 PM
Administrator
 
05GTO's Avatar
 
Join Date: Oct 2004
Location: Deliverance, GA
Posts: 5,132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
I would recommend that you join our sister forum and ask the question there as well,

2004-2006 GTO Source

Randy


05GTO is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
where do I start? ho67rag 1964-1974 Tempest, LeMans & GTO Projects, Barn Finds & Restoration Discussions 11 08-02-2012 10:14 PM
Help ? 71 lemans wont start, not even crank. ?? projectszero 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 4 01-05-2011 06:41 PM
where to start Tmpowdercoating 2004-2006 GTO General Discussion 4 04-30-2010 10:42 AM
I'll Start it... Zrocket The Lounge 6 12-28-2009 09:53 AM
It's a start Green Mountain Goat Member Introductions 4 08-08-2006 08:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome