Please Help Downshifting Issue - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-28-2014, 07:04 PM Thread Starter
 
Join Date: Oct 2013
Location: NJ
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Please Help Downshifting Issue

Hey guys I have a problem downshifting from 3rd to 2nd where the car literally doesn't slow down. It allows me to shift down to 2nd no problem no grinding, but it doesn't slow down even with a rev match and the mixture of brakes unless I really step down on them. I've always used engine braking, but this is a real problem. Also 2nd gear has always been an issue with my car as upshifting to 2nd is not easy and grinds half the time. My mechanic tells me that my 2nd gear synchro is worn, could this be the downshifting issue i'm witnessing? All help is appreciated!
prayforgray01 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2nd Gear Popping out when downshifting prayforgray01 Service, Maintenance and Technical Discussion 0 11-23-2013 06:45 PM
Still having the same issue..... xconcepts 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 3 06-17-2013 10:24 PM
Anyone with this issue...? TorrrridGTO 2004-2006 GTO General Discussion 2 11-04-2007 06:39 PM
Ac Issue KenMan911 Service, Maintenance and Technical Discussion 3 06-30-2007 02:33 AM
Does any have issues with downshifting to 1rst? Virus E Service, Maintenance and Technical Discussion 19 12-22-2006 08:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome