possible AC problems - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-18-2016, 07:07 PM Thread Starter
 
Join Date: Oct 2012
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
possible AC problems

so i just got back into town and realized i might have a problem with my AC. i know how technical the AC system is but maybe someone can suggest something.

symptoms: the ac seems to stop working in slower traffic, on the highway, the thermometer says it gets colder but not cold.

the blower is working

i can hear the ac kick on from inside the car when switched on

and i checked the 2 fuses under the hood for the condenser fans, both were good and so was the fuse for the blower.

recently i installed new motor mounts (hinson, love them) so i did have to jack the engine up to install them, but i did not hear any escaping gas from any lines, so i dont think i pinched a line or loosened any fittings.

im kinda leaning towards an electrical issue. any suggestions??

2006 m6 phantom black GTO:
kooks long tube headers
kooks cat-less mids
bassani cat back
ripstick
lingenfelter intake
BMR drag Bags
The Black Mongoose is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-11-2016, 01:14 AM
 
GTO44's Avatar
 
Join Date: Apr 2016
Posts: 319
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Mine was doing this a while. One of my fans had taken a poo. Even after I got a new fans (and a new radiator cause my stock one had a hole in it) it was still doing. Everytime i stopped with the AC on it would start blowing hot.

Finally tracked it down to a blown relay on the fuse block under the hood. There are 3. I replaced all 3 and it's been perfect ever since!

2006 GTO M6

Motor - Stock with Vararam
Bunch of suspension
Bunch of brakes
Stock tune

365/368 std
12.81 @ 110.6 2.03 60'
GTO44 is online now  
post #3 of 3 (permalink) Old 04-11-2016, 05:03 PM
 
Lemans guy's Avatar
 
Join Date: Oct 2014
Location: Nashville, Tennessee
Posts: 676
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Relay should be checked and not cooling at idle could be a fan issue or a clogged condenser, air in system, a plugged orifice tube, low freon. You should make sure your condenser is free of dead bugs and road dirt and debris as the system depends on that to exchange the heat from the freon to the air, it is of course in front of the radiator and looks like a radiator, I apologize if you know this already.

If all that is working a system check, with an evacuation and fresh recharge may help it cool better. These old systems have the compressor run constantly, so if yours is running that sounds ok. But A/C systems leak, and when they start not cooling if it is not some of the things we discussed..it is usually a small leak.
Lemans guy is online now  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C problems ChargerCop 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 1 05-12-2009 02:27 PM
AC problems 04BLUEGOAT Service, Maintenance and Technical Discussion 2 04-27-2009 10:32 PM
Any Problems? ridgegoat 2004-2006 GTO General Discussion 33 07-03-2006 12:02 PM
Problems already!!!! kllrvet 2004-2006 GTO General Discussion 11 10-09-2005 01:43 AM
04 problems RiceEaterFordBeater 2004-2006 GTO General Discussion 1 03-01-2005 05:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome