Safe Mode question - Pontiac GTO Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 04-22-2010, 08:55 AM Thread Starter
 
Join Date: Oct 2008
Location: Iowa
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Safe Mode question

Right after an oil change my 05 GTO's service engine soon light came on. On the way home it went into Safe Mode and the car died. After I got it started I took it home and looked it over. After I messed with the gas cap the SES light went off and was able to drive for a few weeks with no issues. Then a few days ago it went into safe mode/shut down, 3 different times on a very short trip. After I got it home I tightened the gas cap and the SES light went off but haven't driven it since. Can a faulty gas cap cause this problem or is it something else. Thanks
FD Prez is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 04-22-2010, 08:58 AM
Former Super Moderator
 
Rukee's Avatar
 
Join Date: Feb 2007
Location: South Central Wisconsin
Posts: 9,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
a faulty gas cap can cause a CEL, but it shouldn't kill the motor while driving.
Rukee is offline  
post #3 of 18 (permalink) Old 04-22-2010, 09:14 AM Thread Starter
 
Join Date: Oct 2008
Location: Iowa
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Rukee View Post
a faulty gas cap can cause a CEL, but it shouldn't kill the motor while driving.
Thanks Rukee. So a faulty gas cap wouldn't send it into safe/low performance mode and kill the motor? Could it be from anything the service center did when they changed the oil. Didn't have any problems until that was done.
FD Prez is offline  
 
post #4 of 18 (permalink) Old 04-22-2010, 10:02 AM
 
jpalamar's Avatar
 
Join Date: Jul 2008
Location: Boyertown, PA
Posts: 3,765
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would think of that as being more of an essmissions issue then preformance. I would also hit up a local AutoZone or something to have the ECU read. Find out why it is in safe mode.

Safe mod also kicked in when Julie's ABS sensor failed.

2003 Corvette Z06 - MGW shifter, Corsa X pipe, Corsa Xtreme exhaust, Texas Speed long tubes w/o cats, PowerStop rotors/pads, Conti DWS tires, C6Z51 F&R sways, C5R headlights, tuned

04 GTO - sold

Last edited by jpalamar; 04-22-2010 at 03:33 PM.
jpalamar is offline  
post #5 of 18 (permalink) Old 04-22-2010, 01:14 PM
 
GM4life's Avatar
 
Join Date: Mar 2007
Location: RAF Lakenheath, UK
Posts: 4,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think safe mode has more to do with the accelerator pedal or throttle body(TPS) being faulty. I'll try to look it up to make sure.


Reduced Engine Power: The scan tool displays Active or Inactive. The scan tool displays Active when the control module receives a signal from the throttle actuator control (TAC) module that a TAC system fault is occurring. The scan tool displays inactive when the engine is operating normally.

TAC Forced Engine Shutdown: This parameter indicates the status of TAC control by the control module. The scan tool will display YES if the engine has been shut down due to a throttle control fault. The scan tool will display NO if the engine has not been shut down by a throttle control fault.




Last edited by GM4life; 04-22-2010 at 01:36 PM.
GM4life is offline  
post #6 of 18 (permalink) Old 04-22-2010, 01:41 PM
 
GM4life's Avatar
 
Join Date: Mar 2007
Location: RAF Lakenheath, UK
Posts: 4,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
More info

Modes of Operation

Normal Mode
During the operation of the throttle actuator control (TAC) system, several modes or functions are considered normal. The following modes may be entered during normal operation:

• Minimum pedal value--At key-up, the engine control module (ECM) updates the learned minimum pedal value.

• Minimum throttle position (TP) values--At key-up, the ECM updates the learned minimum TP value. In order to learn the minimum TP value, the throttle blade is moved to the closed position.

• Ice break mode--If the throttle is not able to reach a predetermined minimum throttle position, the ice break mode is entered. During the ice break mode, the ECM commands the maximum pulse width several times to the throttle actuator motor in the closing direction.

• Battery saver mode--After a predetermined time without engine RPM, the ECM commands the battery saver mode. During the battery saver mode, the TAC module removes the voltage from the motor control circuits, which removes the current draw used to maintain the idle position and allows the throttle to return to the spring loaded default position.

Reduced Engine Power Mode(Hint, Hint Toyota!!!)
When the ECM detects a condition with the TAC system, the ECM may enter a reduced engine power mode. Reduced engine power may cause one or more of the following conditions:

• Acceleration limiting--The ECM will continue to use the accelerator pedal for throttle control, however, the vehicle acceleration is limited.

• Limited throttle mode--The ECM will continue to use the accelerator pedal for throttle control, however, the maximum throttle opening is limited.

• Throttle default mode--The ECM will turn OFF the throttle actuator motor and the throttle will return to the spring loaded default position.

• Forced idle mode--The ECM will perform the following actions:

- Limit engine speed to idle by positioning the throttle position, or by controlling the fuel and spark if the throttle is turned OFF.

- Ignore the accelerator pedal input.

• Engine shutdown mode--The ECM will disable fuel and de-energize the throttle actuator.



GM4life is offline  
post #7 of 18 (permalink) Old 04-22-2010, 02:22 PM Thread Starter
 
Join Date: Oct 2008
Location: Iowa
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My GTO beeps 3 or 4 times then shuts completely down with a message of Safe Mode/Low Performance Mode. I wait a couple of minutes and it restarts but the SES light is on. A few blocks or miles later it does it all over again.
FD Prez is offline  
post #8 of 18 (permalink) Old 04-22-2010, 03:01 PM
Former Super Moderator
 
Rukee's Avatar
 
Join Date: Feb 2007
Location: South Central Wisconsin
Posts: 9,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Go get the computer scanned for codes at autozone or somethin.
Rukee is offline  
post #9 of 18 (permalink) Old 04-27-2010, 09:59 AM Thread Starter
 
Join Date: Oct 2008
Location: Iowa
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just had the GTO scanned and it came back as a faulty ECM..almost $600 including the scan. Does thsi make sense?
FD Prez is offline  
post #10 of 18 (permalink) Old 04-27-2010, 02:36 PM
 
GM4life's Avatar
 
Join Date: Mar 2007
Location: RAF Lakenheath, UK
Posts: 4,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
What was the code?



GM4life is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
"SAFE MODE" problem fukuhos Service, Maintenance and Technical Discussion 1 03-13-2010 09:36 PM
Safe Cruising RPM khinton 1964-1974 Tempest, Lemans & GTO General Discussion 11 03-13-2010 10:46 AM
HELP! Safe Mode after VR Intake Install nron Intake and Exhaust Discussions 1 01-01-2010 10:12 AM
Having problems with idle/misfires/safe mode michaelo2 Engine Discussions 6 06-19-2009 08:22 AM
SAFE MODE PROBLEM/Engin BAD Lynzzgto Service, Maintenance and Technical Discussion 5 01-26-2006 02:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome