Safety Mode?? - Pontiac GTO Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 06-30-2010, 05:27 AM Thread Starter
 
Join Date: Jun 2010
Location: Camp Pendleton,CA
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Safety Mode??

So I picked up a 06' GTO after driving a stang for 7 years, well as I'm rolling down the street I slam the pedal reaching 5k Rpms and bam car stops accel. And gauges says safety mode- reduced performance and the check engine comes and stays on! Help please, thanks!
LS2Baaahad is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-30-2010, 06:49 AM
 
06SixOhGoat's Avatar
 
Join Date: Jun 2010
Location: Upper Marlboro, Maryland
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Go to your local Advance Auto Parts or AutoZone. They read OBDII for free. They will give you a code and you can look it up online.

Good Luck though man

Tony Smith
2006 M6 Torrid Red/Red Interior
Intake and Resonator and Muffler Delete.
!!!COMEING SOON ON WAITING LIST AT SHOP!!!
Ported Intake Mani and Trottle Body and Street Tune
06SixOhGoat is offline  
post #3 of 12 (permalink) Old 06-30-2010, 08:23 AM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
Could be several things but pedal sensor and bad MAF (or connection) come to mind

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
 
post #4 of 12 (permalink) Old 06-30-2010, 09:17 AM
 
jpalamar's Avatar
 
Join Date: Jul 2008
Location: Boyertown, PA
Posts: 3,765
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Julie's went into safemode when the ABS sensor failed I think also... but there are so many things that could be the issue you really won't know until you have the code checked.
jpalamar is offline  
post #5 of 12 (permalink) Old 06-30-2010, 03:16 PM Thread Starter
 
Join Date: Jun 2010
Location: Camp Pendleton,CA
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by 06SixOhGoat View Post
Go to your local Advance Auto Parts or AutoZone. They read OBDII for free. They will give you a code and you can look it up online.

Good Luck though man
I have a reader and it sending out this code p1516, but didn't get a chance to look it up. I can go any faster than 20mph and 1st gear. Not cool
LS2Baaahad is offline  
post #6 of 12 (permalink) Old 06-30-2010, 03:53 PM
 
HP11's Avatar
 
Join Date: Apr 2009
Location: San Bernardino, Ca.
Posts: 2,603
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
P1516 - Throttle Actuator Control (TAC) Module Throttle Actuator Position Performance.

Clear the code. If it comes back either your Throttle Position Sensor or Throttle Actuator is bad.

Question: Was your T/C on when you floored it? Just curious....

2005 Pontaic GTO - CGM 6 Speed (My car)
2017 Chevrolet Colorado 2WT (My daily driver)
2010 Mercedes Benz C300 Sedan (Wife's car)
2014 Kia Rio LX (Wife's daily driver)
HP11 is online now  
post #7 of 12 (permalink) Old 06-30-2010, 04:51 PM Thread Starter
 
Join Date: Jun 2010
Location: Camp Pendleton,CA
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by HP11 View Post
P1516 - Throttle Actuator Control (TAC) Module Throttle Actuator Position Performance.

Clear the code. If it comes back either your Throttle Position Sensor or Throttle Actuator is bad.

Question: Was your T/C on when you floored it? Just curious....
The T/C was off the time it's happened I cleared the SES and then it happens again as I was jumping on freeway yeaturday
LS2Baaahad is offline  
post #8 of 12 (permalink) Old 06-30-2010, 05:37 PM
 
HP11's Avatar
 
Join Date: Apr 2009
Location: San Bernardino, Ca.
Posts: 2,603
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Well if the code comes back you'll probably have to take it to the dealer. Based on your answer it doesn't apply here but my question about the T/C has to do with the fact that almost everytime I've heard of anyone doing burnouts with the T/C on they've ended up with that code.

2005 Pontaic GTO - CGM 6 Speed (My car)
2017 Chevrolet Colorado 2WT (My daily driver)
2010 Mercedes Benz C300 Sedan (Wife's car)
2014 Kia Rio LX (Wife's daily driver)
HP11 is online now  
post #9 of 12 (permalink) Old 06-30-2010, 09:26 PM
 
taylorb765's Avatar
 
Join Date: Jun 2010
Location: Nebraska
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The exact same thing happened to me and the ecm was bad.

2006 GTO Edelbrock shorty headers, x pipe, muffler deletes, K&N airbox, diablosport 91 octane tune, billet short throw shifter.

1.90 60ft, 8.46 1/8, [email protected] 1/4
taylorb765 is offline  
post #10 of 12 (permalink) Old 06-30-2010, 09:46 PM Thread Starter
 
Join Date: Jun 2010
Location: Camp Pendleton,CA
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by HP11 View Post
Well if the code comes back you'll probably have to take it to the dealer.
Yea I called the dealer today, I have to take it in early in the morning hopefully they find the problem and fix it the same.
LS2Baaahad is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Safe Mode question FD Prez Service, Maintenance and Technical Discussion 17 10-08-2010 06:50 PM
Safety Mode GTOWS6GUY Service, Maintenance and Technical Discussion 4 03-24-2008 03:04 PM
Launch Mode 1gto Engine Discussions 2 01-18-2007 11:38 PM
safety mode Sporaclic 2004-2006 GTO General Discussion 19 05-13-2006 03:08 PM
safety mode EEZ GOAT Service, Maintenance and Technical Discussion 19 09-24-2005 07:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome