T/C problem - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-10-2006, 09:03 AM Thread Starter
 
Join Date: Jan 2006
Location: Florida
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
T/C problem

Anybody experience this? I have an 04GTO, and usually run with the traction control off. My wife drove it the other day with the T/C on, and said when she got to 60 mph, the throttle would not allow additional speed and the engine acted like it was being prevented from going faster. I trie dit, and sure enough. It acts like the speed limiter is preventing the car from going over 60. Any suggestions? I have an appoiuntment to take it to the dealer tomorrow.
ThePrincipal is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-10-2006, 09:36 AM
 
Join Date: Feb 2006
Posts: 850
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The only suggestion I have is make sure when the dealer drives the car, make sure either you or your wife is present during the drive. This way, if the tech has any questions, either one of you will be there to answer.

This is the first time I've heard of this problem though...let us know what happens.
GOATGIRL is offline  
post #3 of 4 (permalink) Old 04-10-2006, 09:54 AM
Premium Member
 
EEZ GOAT's Avatar
 
Join Date: Jul 2005
Location: Phenix City Alabama
Posts: 2,626
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to EEZ GOAT
sounds like the wheels are slipping causing the t/c to activate
EEZ GOAT is offline  
 
post #4 of 4 (permalink) Old 04-10-2006, 07:52 PM
 
Join Date: Mar 2005
Posts: 1,196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by ThePrincipal
Anybody experience this? I have an 04GTO, and usually run with the traction control off. My wife drove it the other day with the T/C on, and said when she got to 60 mph, the throttle would not allow additional speed and the engine acted like it was being prevented from going faster. I trie dit, and sure enough. It acts like the speed limiter is preventing the car from going over 60. Any suggestions? I have an appoiuntment to take it to the dealer tomorrow.
Grab that lever sticking up between the front seats and pull it straight back. Is that better?
Wing_Nut is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome