Water Pump or T-Stat?? - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-08-2015, 11:09 PM Thread Starter
 
pocketmaster's Avatar
 
Join Date: Feb 2010
Location: Weatherford, Tx
Posts: 252
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Water Pump or T-Stat??

I recently replaced both serpentine belts on my 05 M6. Prior to replacing is had a hell of a squeel. So two days later I noticed the temp on my guage climb a couple notches on the guage and instantly drop back down to normal operating temp (I'm assuming the t-stat was stuck or the fan kicked in). This happened again yesterday, after following a hard freeze over night (15 Deg). The vehicle had been running for a good 30 min on the freeway prior to the temp starting to climb. No coolant leaking. No more squeeling since I changed the belts. I'm thinking T-Stat is sticking, however that T-Stat was replaced last year so its not very old. Guess it could be defective....thoughts??

God Bless Billiards!!!!
pocketmaster is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-09-2015, 07:53 AM
 
SANDU002's Avatar
 
Join Date: Oct 2004
Location: BROOKEVILLE, MD
Posts: 1,116
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
If the water pump is leaking who will see antifreeze underneath the car and around the pump itself.


67 Post Coupe,
69 RA III Judge
06 BOM, M6, 18's
SANDU002 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Service, Maintenance and Technical Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
64 water pump djones3158 1964-1974 Tempest, Lemans & GTO Complete Engine Compartment Discussion 4 12-12-2014 12:52 PM
68 water pump JeffW 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 5 12-16-2013 12:02 AM
'69 water pump Q etewald 1964-1974 Tempest, Lemans & GTO General Discussion 2 06-15-2012 12:56 PM
water pump Topkat 1964-1974 Tempest, Lemans & GTO General Discussion 3 03-06-2011 12:27 AM
water pump Topkat 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 3 11-22-2010 01:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome