SCSS engine & Tranny Mounts - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-20-2014, 05:10 PM Thread Starter
 
SIXO GTO's Avatar
 
Join Date: Nov 2013
Location: Pittsburgh,PA
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
SCSS engine & Tranny Mounts

Today I installed my Team SCSS mounts on my 13k 2005 m12 gto & I was wondering if anyone else has put these on their car ?? install was pretty easy on my frontend rack at work... question is HOLY drivetrain noise & vibration... I expected some but DAMN !!! the 1 thing I do like is my shifts feel way more precise & smooth but it feels & sounds like I have solid mounts hope they feel better once they get a few hundred miles on them... I have a weird vibration maybe driveshaft related idk ??? thinking of getting a driveshaft shop 1 piece to do away with the carrier bearing/gulibos set up ...I very rarely drive over 120-130 if at all so the 1 piece should work fine... the dealer installed b&m shifter works good but has been vibrating as of lately thinking about getting rid of it or seeing if the little Kevlar cup was installed on it as b&m says if not they tend to make a slight annoying noise once they wear alittle ?? any help or feedback would be great as im new to the gto's problems/issues slowly upgrading as the problems arise ! ! svede I know you always have something on your mind & hoping you can help me tomorrow is my drag bag install still squats 2 much on acceleration even with the new koni's & lovells 370 mm rear springs ( damned wheel hop ) ANY! WITH ADVICE I would really appreciate it ..
SIXO GTO is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-28-2014, 12:12 AM
 
Join Date: Jun 2014
Location: California
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I have the hinson motorsports poly engine mounts and there is no vibration at all. Look it up and compare the pics. My car has a big cam and my friend was telling me that it will shake a lot but is totally fine. I had shifter noise when I put the mgw-p but its gone after 100 miles. Driveshaft vibration - I have G-force1320 one piece and I have taken it to 160 with no issues. I also have Koni (the adjustable ones) and King springs and the car squats just a little (shocks are not even on max setting).
Qnko is offline  
post #3 of 4 (permalink) Old 06-28-2014, 12:56 AM
 
Steamwalker's Avatar
 
Join Date: Mar 2012
Location: Vista, CA
Posts: 282
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would expect there to be quite a bit of vibration introduced when switching to poly motor and trans mounts. I'd never have them in my car. With that said, I've rode in a goat with SCSS motor and trans mounts and never noticed anything distressing about the ride quality.

06/QSM/A4
SoCal Goat Club
Steamwalker is offline  
 
post #4 of 4 (permalink) Old 06-28-2014, 09:25 AM
 
Join Date: Nov 2013
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I put Hinson motor mounts and a Revtech trans mount insert in mine and picked up quite a bit of vibration.


Sent from AutoGuide.com Free App
younggto is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Drive train, suspension, alignment and brakes.

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine mounts HELP! Bigalsworth 1964-1974 Tempest, Lemans & GTO Complete Engine Compartment Discussion 3 11-27-2012 03:47 PM
SCSS Mounts SWGOAT 2004-2006 GTO General Discussion 3 02-13-2012 10:58 PM
WTB SCSS mounts SWGOAT 2004-2006 GTO General Discussion 0 02-05-2012 09:19 AM
Enigne & Trans mounts mebuildit Drive train, suspension, alignment and brakes. 1 09-11-2011 07:54 PM
Solid Engine Mounts ElementS8ing Engine Discussions 2 07-18-2006 10:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome