Cruise control lever broken? - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-16-2008, 02:51 PM Thread Starter
 
Join Date: Jun 2007
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cruise control lever broken?

Hi! I have the problem that I can't set my cruise control. I can activate it by pushing the button but when I want to set the speed it doesn't work. I flipped the lever a couple of times in a row and I could see 'active' come on for a split second in the main LCD screen (besides 'cruise'), but it would turn back off right away. Does anybody know what causes that and what it would take to fix it?

Thank y'all
CrazyGerman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-16-2008, 05:28 PM
 
GM4life's Avatar
 
Join Date: Mar 2007
Location: RAF Lakenheath, UK
Posts: 4,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If your car is still under warranty take it to the dealer. What year is your car?



GM4life is offline  
post #3 of 4 (permalink) Old 07-17-2008, 06:35 AM Thread Starter
 
Join Date: Jun 2007
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's an 05 with 36k miles on it
CrazyGerman is offline  
 
post #4 of 4 (permalink) Old 07-19-2008, 09:54 AM Thread Starter
 
Join Date: Jun 2007
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Things got worse

Things got worse on Thursday. I was planning to take the goat to go to D.C. on Friday but then this happened: I was driving home n Thursday afternoon and the check engine light came on. I thought 'oh well, gotta take it to the shop when I come back from D.C. 5 minutes later I wanted to use my turn signal but it didn't come on... Neither right nor left turn signal worked though the 4-way flashers were working. I really thought that the lever was bad now, since with the 4-way flashers working a bad fuse shouldn't be the reason.

So I dropped it off at a GM shop and took my girlfriends car to D.C. I got a call fom the shop while I was in D.C. with an explanation what was wrong.

The turn signals didn't work bc of a blown fuse... Makes no sense to me but what the hell. The cruise control didn't work because a code was set in the computer (although the check engine light came on 2 days after it had stopped working).

The code that was set was from the clutch pedal sensor. If you rest your foot on the clutch (during slow moving traffic) it is possible that the 'clutch released' switch doesn't make. This will keep the ECM from seeing transitions while driving above and then below the vehicle speedslisted for setting the DTC. This can cause a false P0833 to set.

Just wanted to share this with my fellow GTO owners in case this happens to somebody else. My goat is running fine again.

Keep on guzzling
CrazyGerman is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Interior Discussions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Code - Catalyst Sys Efficiency Threshold (bank 1 & Bank 2) cjsuttonx Intake and Exhaust Discussions 5 08-24-2008 07:42 PM
T/C & Cruise Control Problem jortegasr Service, Maintenance and Technical Discussion 7 02-23-2007 01:28 PM
Computer guages (Autotap OBDII-CAN Diagnostic) MJGTOWISH 2004-2006 GTO General Discussion 3 12-03-2006 10:01 AM
cruise control not working socal gto Service, Maintenance and Technical Discussion 2 06-03-2006 03:29 PM
GTO concept car to be at Woodward Dream Cruise Troy Roberts 2004-2006 GTO General Discussion 15 09-02-2004 11:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome