Help! my stereo fried after battery replace - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 08-17-2015, 02:00 PM Thread Starter
 
Join Date: Aug 2015
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Help! my stereo fried after battery replace

Hi, i have a GTO 2004 the 5.7 and recently did a battery change and (the lady at oreilly gave me the wrong one over voltage ) and fried my stereo anyone know were can i find this fuse? inside the stock radio or the inside column fuse box?
EddieGTO2004 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 08-17-2015, 04:20 PM
 
rickm's Avatar
 
Join Date: Feb 2012
Location: new york state
Posts: 633
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
the battery she gave you wasn't 12 volts? sure about that? look in the manual for fuse id n location. they r color coded.
rickm is offline  
post #3 of 9 (permalink) Old 08-17-2015, 06:44 PM
Former Moderator
 
svede1212's Avatar
 
Join Date: Oct 2005
Location: Grand Rapids, Michigan
Posts: 4,081
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 25 Post(s)
Garage
Sure it didn't get hooked up backwards? It's hard to find one that isn't 6 or 12 volts. BTW I think hat fuse is under the steering wheel. That panel hinges down

2004 Blk/Rd M6
6.3 litre LS1

Built and tuned by svede
svede1212 is offline  
 
post #4 of 9 (permalink) Old 08-17-2015, 10:28 PM Thread Starter
 
Join Date: Aug 2015
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by svede1212 View Post
Sure it didn't get hooked up backwards? It's hard to find one that isn't 6 or 12 volts. BTW I think hat fuse is under the steering wheel. That panel hinges down
also did hook up backwards accidently the new battery had the negative and positive vice versa and didnt look at first but good thing it was slight tap i took it off right away...(i was pissed when i went back to return the battery with the lady) i got the right one and hooked it up and turned right up no fry just the strereo i checked all the fuses also the radio but all good...the the stock radio has a fuse behind it?
EddieGTO2004 is offline  
post #5 of 9 (permalink) Old 08-18-2015, 01:19 AM
Former Moderator
 
Join Date: Oct 2014
Location: Lake Arrowhead, Ca.
Posts: 1,499
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Reversing the polarity on a radio may not blow a fuse but it could take out a transistor or a pre driver or both.
Diodes are like a one way gate to protect these components but all bets are off when you reverse the polarity.
Did you smell anything or hear a pop out of the radio when you did this?
The board in it may have surface mounted components and I only know one tech that has the equipment to work on these boards.
Look in your manual and find the radio fuse and don't just look at it test it with a DMM and if you don't have one replace the fuse with a new one.
If this isn't it you may have to source another radio.
Goat Roper is offline  
post #6 of 9 (permalink) Old 08-18-2015, 01:29 AM Thread Starter
 
Join Date: Aug 2015
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Goat Roper View Post
Reversing the polarity on a radio may not blow a fuse but it could take out a transistor or a pre driver or both.
Diodes are like a one way gate to protect these components but all bets are off when you reverse the polarity.
Did you smell anything or hear a pop out of the radio when you did this?
The board in it may have surface mounted components and I only know one tech that has the equipment to work on these boards.
Look in your manual and find the radio fuse and don't just look at it test it with a DMM and if you don't have one replace the fuse with a new one.
If this isn't it you may have to source another radio.

thanks for your help bro...i found some posts around the web with the same situation as mine on a gto and the 2 guys just switched the fuse and the stereo turned on( hope so )

i didnt hear anything inside but outside i heard the fans turn on tomorrow ima check all fuses that everything is working.

i checked all the fuses inside the car and outside and they look good... everything else works except the radio but ima double check on wipers and check the laternator and fans...(forgot to check those)

tomorrow ill update to see i fix it problably help someone else in the future...
EddieGTO2004 is offline  
post #7 of 9 (permalink) Old 08-18-2015, 02:55 AM
Former Moderator
 
Join Date: Oct 2014
Location: Lake Arrowhead, Ca.
Posts: 1,499
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Hopefully the fuse protected it and you can't always tell visually with fuses so it can look good but still be blown.
It is a good sign that others have gone through this and their radios survived.
Usually a fan will just turn backwards when you reverse polarity but it doesn't hurt the fan.
Get a cheapo DMM to check fuses (continuity) and always take them out of the holder to test so you don't get a false reading.
Goat Roper is offline  
post #8 of 9 (permalink) Old 08-19-2015, 12:21 AM Thread Starter
 
Join Date: Aug 2015
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Goat Roper View Post
Hopefully the fuse protected it and you can't always tell visually with fuses so it can look good but still be blown.
It is a good sign that others have gone through this and their radios survived.
Usually a fan will just turn backwards when you reverse polarity but it doesn't hurt the fan.
Get a cheapo DMM to check fuses (continuity) and always take them out of the holder to test so you don't get a false reading.
thanks bro...i bought a ford removal stereo kit and got the stereo out and the fuse was blown and change it it and works now. Thanks for your help its my first GTOso im learning all this goodies.
EddieGTO2004 is offline  
post #9 of 9 (permalink) Old 08-19-2015, 01:25 AM
Former Moderator
 
Join Date: Oct 2014
Location: Lake Arrowhead, Ca.
Posts: 1,499
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Excellent!
Glad to hear you didn't need to replace your radio.
Goat Roper is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Interior Discussions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bout fried my motor last week on vacation dustyminpin Engine Discussions 8 10-12-2011 05:57 AM
i think i fried my MSD box tyler t 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 9 02-06-2011 09:15 PM
When your battery was dead, did your battery light stay on? SueY816 2004-2006 GTO General Discussion 7 05-31-2010 05:54 PM
Do I need to replace the old dampener? bigcode99 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 2 10-02-2007 10:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome