Need some help with electrical problems - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-01-2013, 03:31 PM Thread Starter
 
Join Date: Oct 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Need some help with electrical problems

Ok so the other day I noticed that I couldn't turn off my lights. They go off automatically but I can't turn them off with the switch. The light display constantly stays on even if I toggle them off. I also noticed later that night that my dash lights weren't working anymore. The digital speedometer still works and can be seen at night but not the back dash where the dials are. Then to top it off last night I was driving and got pulled over because apparently my tail lights weren't working. All this has happened within the last week. I didn't notice the tail lights till last night. They all seem to be related to the same problem or at least I hope. I was wondering if anyone has experienced any of these problems or have any solutions to fix this problem. I have an 05 6.0 gto. Any help or suggestions are appreciated. Thank you in advanced.
Jmckinney1991 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-01-2013, 03:43 PM
Former Super Moderator
 
Rukee's Avatar
 
Join Date: Feb 2007
Location: South Central Wisconsin
Posts: 9,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Welcome to the forums.
On most cars the tail lights are tied to the dash lights to let you know you don't have tail lights. Check the fuses.
Rukee is offline  
post #3 of 6 (permalink) Old 10-01-2013, 03:46 PM Thread Starter
 
Join Date: Oct 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ok thank you! I will take a look at that and let you know if that ends up being the problem.
Jmckinney1991 is offline  
 
post #4 of 6 (permalink) Old 10-01-2013, 06:22 PM Thread Starter
 
Join Date: Oct 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That was the problem. Everything is fixed. Thank you!
Jmckinney1991 is offline  
post #5 of 6 (permalink) Old 10-01-2013, 10:32 PM
Former Super Moderator
 
Rukee's Avatar
 
Join Date: Feb 2007
Location: South Central Wisconsin
Posts: 9,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Rukee is offline  
post #6 of 6 (permalink) Old 10-02-2013, 06:35 AM
 
HP11's Avatar
 
Join Date: Apr 2009
Location: San Bernardino, Ca.
Posts: 2,603
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Keep an eye on that for a while to make sure it's just old age for the fuse rather than some other problem that cause it to blow.

2005 Pontaic GTO - CGM 6 Speed (My car)
2017 Chevrolet Colorado 2WT (My daily driver)
2010 Mercedes Benz C300 Sedan (Wife's car)
2014 Kia Rio LX (Wife's daily driver)
HP11 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > The 2004-2006 GTO > Interior Discussions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
69 electrical problems JJs69GTO 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 11 07-06-2011 11:34 AM
Electrical Problems dahd11 1964-1974 Tempest, LeMans & GTO Technical and Electrical Wiring 19 03-03-2011 07:37 PM
cold weather electrical problems? Q8 GTO 2004-2006 GTO General Discussion 1 02-03-2010 10:58 AM
Att. All Gto Owners. Please Read. Electrical Problems popkorn77 Service, Maintenance and Technical Discussion 109 12-14-2009 09:21 AM
Lock problems continue + more electrical issues gtogirl Service, Maintenance and Technical Discussion 4 09-27-2008 12:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome