Oil question - Pontiac GTO Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-04-2007, 09:45 PM Thread Starter
 
fiddler_red's Avatar
 
Join Date: May 2007
Location: Chicago
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Skype™ to fiddler_red
Oil question

I've been reading on this forum many members that swear by using synthetic only after break in. I bought a GTO recently and put just 1500 miles on her. This car has the Mobil 1 synthetic oil that all LS2's ship with. Should I change it to a regular oil and then go through the break in process again before switching back to synthetic? If so, which oil should I use and for how many more miles?

Please advise me, many here are well versed in all of this and I'm new to it all. It's my first new car, I don't want to screw it up! Thanks for all your input.
fiddler_red is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-13-2007, 11:28 PM
 
Join Date: Feb 2006
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
test
malum in se is offline  
post #3 of 4 (permalink) Old 06-13-2007, 11:28 PM
 
Join Date: Feb 2006
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
So I don't understand why when I post, my sig isn't showing?
malum in se is offline  
 
post #4 of 4 (permalink) Old 06-14-2007, 07:31 AM
 
silversport's Avatar
 
Join Date: Mar 2007
Location: Chicagoland, USA
Posts: 1,274
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You don't need to use anything but Mobil 1 as from the factory...no break in oil is needed...Mobil 1 has been the official oil of Corvette since at least as far back as 1992...if there was a break in oil required and not used there would be zillions of LT-1, LT-4, LT-5, LS-1, LS-2, LS-7, etc. ad nauseum needing warranty repairs...and GM would be broke...
Mobil 1 is used by Viper, Aston Martin, Porsche, Corvette, GTO, etc., etc., etcetera!
Enjoy.
Bill

**QSM/RH/A4/17**1 of 52**
Like what you've got?...Thank a Vet!
silversport is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac GTO Forum > GTO Forum Help > Test Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac GTO Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome