Pontiac GTO Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have an 05 with door lock issues.
1.The driver Door Lock Pull acts like its stripped. I pull up on the lock and it comes off. Are these easy to replace or do I need to take the door panel off.

2. Also whenever I use the key fob to lock it, the horn chirps 3x. I have it set to off on the control panel but still blows the horn everytime I lock it. I've tried disconnecting and connecting all power from the battery but that didn't work either. Any ideas how to fix this would be really appreciated.

3.The key fob doesn't lock the driver door but the key does lock and unlock it.
Love my GTO but this stuff is driving me crazy..HELP
 

·
Super Moderator
Joined
·
8,430 Posts
Sounds like a BCM (Body Control Module) problem. Door Actuators also will give a problem similar to this, however with the horn chirping, I am suspecting the BCM. The BCM is located up under the dash behind the glove box.

As far as the lock knob; Cleveland pick apart ought to have one. Late Model Auto Recyclers (northeast ohio auto salvage) Late Model auto parts in Northern Ohio

I haven't had a problem with mine but are you sure they are not pressed on and it is no longer attached? The door panel will have to come off to get to the problem. Maybe once it's off you can get it back on? If you are seeing threads in it and it looks stripped.....try this site, maybe they have what you need.
++ TIME-SERT Threaded inserts for stripped threads, threaded inserts, thread repair stripped sparkplug's, Ford sparkplug blowouts, threaded inserts threaded, repair stripped threads, stripped threads, inserts threaded inserts, Ford spark plug repair,
 

·
Registered
Joined
·
1,448 Posts
You control the horn chirps with the mode set on the dash. I programmed mine not to chirp at all but to only flash when the car is locked. Use the manual and run through the options.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
You control the horn chirps with the mode set on the dash. I programmed mine not to chirp at all but to only flash when the car is locked. Use the manual and run through the options.
Thanks for your help. I have the mode programmed to indicators only but the horn still blows when i lock it. Is replacing the BCM a DYI or a repair shop job?
 

·
Premium Member
Joined
·
4,162 Posts
It's your actuator, I had this problem on my driverside door it will chirp 4x when I lock the door with the remote. If your car is under warranty have the dealership deal with it. If I remember correctly the door lock knob is clipped onto the lock rod. If your rod is binding it may cause a problem with your car trying to lock, if your locks is out of sequence it will cause the horn to chip more than once.
 

·
Registered
Joined
·
234 Posts
Mine just started doing the exact same thing with the key being the only way to lock it, but the remote will unlock it. I didn't check to see if the factory remote does the same horn blow as I use an aftermarket alarm and never use the stock.

My car is no longer under warranty though. I'm trying to find the part that I need. GM parts direct lists it as "Actuator Back" if that is the right piece. Can someone let me know that knows?
 

·
Super Moderator
Joined
·
8,430 Posts
There are 2 different GM parts sites. This site offeres the same part for less (96.32) gmpartsdirect.com: Alternate GM Catalog

This site offers the same part for more (102.41)
http://www.gmpartshouseusa.com/partlocator/index.cfm?action=getJointLocator&siteid=214638&chapter=&sectionids=0,3263&groupid=51895&subgroupid=2378&make=28&model=GTO&year=2005&catalogid=2&displayCatalogid=0

Both list the actuator as "Actuator back" its the only actuator listed. I would think that's it. To double check this you may be wise to call a Pontiac dealers parts dept and inquire about the actual part number and what the part is listed as and double check to make sure there is no LorR. It appears the actuator may be a R&L part.
 

·
Registered
Joined
·
234 Posts
Mine ended up being a bad output on my aftermarket alarm. I tore it out and I now much prefer my factory alarm. I guess I was one of the lucky ones that was just a fluke. Sure, the range on the alarm isn't as good as the aftermarket, but I kept breaking the 2-way pagers and even with the standard aftermarket alarm remote I kept hitting the unlock button even on the other side of the property of my work and unlocking it. I guess 2 years out of an aftermarket alarm is good, but factory is so well integrated since it uses the display.

By the way, to the original poster, if it's still acting up, go into the menu that pops up when you first start the car. If you don't already have it set, change the Lock in Drive setting to yes. If it locks and unlocks every time you put it in gear or take it out of gear, it's probably a BCM issue. Some people are having to leave this setting on to be able to lock the doors with the remote which should signify a bad BCM.
 
1 - 8 of 8 Posts
Top