Pontiac GTO Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Just put in the zex nitrous kit(100shot) on my 05. got a full slick on the rear, and a cold air intake. Car is launching hard on the street, and feels strong. Gonna see what she runs on the track this weekend. Anyone have spray on their 05 who might be able to give me a number what she may run.
 

·
Registered
Joined
·
57 Posts
I nver put nos on a GTO, but I did have the N.O.S. 5177 dry kit on my 98 Corvette, auto and with the 100 shot I picked up 1 second at the strip and about 10 mph exactly. When I pick up my 05 GTO in spring I plan on putting the same system back on that I had on my c5. Are you an a4 or a m6?
 

·
Registered
Joined
·
8 Posts
I say you will run somewhere in the low to high 12's at around 105 - 113.

That's just my two cents.

I am not a big fan of Nitrous Oxide, say good bye to the longevity of your motor and less to claim. Why are you running slicks on the street?
 

·
Registered
Joined
·
42 Posts
1fast05GTO said:
Just put in the zex nitrous kit(100shot) on my 05. got a full slick on the rear, and a cold air intake. Car is launching hard on the street, and feels strong. Gonna see what she runs on the track this weekend. Anyone have spray on their 05 who might be able to give me a number what she may run.
Make some runs without the spray. I am curious to see what it'll run mostly stock. I plan on hitting the strip in the next couple weeks. Anyone in Southern California want to meet up in Palmdale for Friday night drags? :cool
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
Just got back from the track.....nitrous didnt work because the bottle fitting broke, but with a slick, cold air, and dump plates opened...car went 12.83 @110.07...i was really hoping for around a 12.6 on motor, but i was having trouble launchin the car with the slicks....couldnt figure out where to launch without bogging or spinning, next time will be better.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
1fast05GTO said:
Just put in the zex nitrous kit(100shot) on my 05. got a full slick on the rear, and a cold air intake. Car is launching hard on the street, and feels strong. Gonna see what she runs on the track this weekend. Anyone have spray on their 05 who might be able to give me a number what she may run.
Just wanted to let everyone know about the 05 times. Well, the nitrous fitting on my bottle was leaking so i was unable to spray the car. But as for motor times. Now the car does have an intake, i ran with a mickey thompson et street 26x10.5x16...with 14lbs....and electric dump plates.first run was a 13.1......launched very slow outta the whole....2nd run broke 12's...but barely...went 12.96.....after puttin pressure back into the tires..16lbs.....car launched at 2600...very hard and was able to run a 12.83 @110.07....I was figuring i was gonna run a 12.60 maybe cause my friend has a vette that goes around that and he barely beat me on the street. Now maybe in 2 weeks, with the spray....i really do hope to break into 11's....the kit is adjustable...but im keeping it at 100. But word of advice to first timers on the track....DO NOT DUMP IT HARD WITH A SLICK OR DRAG RADIAL.....keep it under 2800 rpm.....not a good feeling with the hopping.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
newagegoat said:
I nver put nos on a GTO, but I did have the N.O.S. 5177 dry kit on my 98 Corvette, auto and with the 100 shot I picked up 1 second at the strip and about 10 mph exactly. When I pick up my 05 GTO in spring I plan on putting the same system back on that I had on my c5. Are you an a4 or a m6?
I am an M6
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #14 ·
TM2FLI said:
Where did you mount the dumps? Also describe your intake. What was the weather conditions where you ran at? Sorry alot of questions..lol. We just ran ours yesterday too with just nittos.
the dumps are mounted right after the cats....i didnt wanna remove the cats cause i really didnt wanna throw an engine code...the weather was around 43 degrees with little wind.....what u guys run with urs
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top