Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Greetings gents, I'm new to the forum and the new owner (less than a week) of 1964 LeMans sport coupe. I'm in the process of fixing the many little things that need work.

One of the items that needs immediate addressing is the turn signals. There are no felt or audible clicks to engage the turn signals on the column lever and they don't cancel either.

Is the culprit for both of these conditions the turn signal cancelling cam? Like this one:
http://www.summitracing.com/parts/OPG-PF8231B/

I'm new at this and any help I can get from those who have boldly gone before would be greatly appreciated. By the way this is a non-tilt column with an aftermarket Grant steering wheel. Thanks.
 

·
Registered
Joined
·
50 Posts
Well - I'll take a stab at it - I'd say if the '64 is anything close to my '69, it's probably the switch itself instead of the cam. At least that was the way mine acted and it turned out to be the switch had cracked - it still worked, but it wouldn't "click" when you moved the lever and it wouldn't cancel when the wheel was turned...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks for the input guys. I was wondering if the steering wheel might be at fault. The horn doesn't quite work right either - sounds muted. Maybe I'll pull the wheel and see if the switch has indeed cracked.
 

·
Registered
Joined
·
704 Posts
the switch needs to be checked out inside the column, but the cam must be matched to the switch if you just replace the cam.
 
1 - 5 of 5 Posts
Top