Pontiac GTO Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Well I finally have my wiper motor working, the previous owner crossed a wire on a new harness. Now I see I have the old style arm, and the blade in there is totally free to move in and out, and it does, mostly out! Anyone know of a better blade to use, maybe a part number? Thanks!
 

Attachments

·
Registered
Joined
·
99 Posts
Discussion Starter #2
All - would anyone be willing to post a pic zoomed on on their 68' wiper? I'm curious how others are set up. Thanks!
 

·
Registered
Joined
·
99 Posts
Discussion Starter #4
Thank you, this is helpful! Can I ask what blade you used? The rubber blade in mine was not fixed in any way, so it could slide in or out. I'm trying to find a proper replacement....
 

·
Registered
Joined
·
99 Posts
Discussion Starter #5
Im starting to wonder if I should just replace both the arm and blade together? Thing is the arm looks original.
 

·
Registered
Joined
·
906 Posts
Part #: WIP 61633

napa classic blade part number

fairly sure these are correct for our 68-72

take your blade with you for a sample

https://www.google.com/search?q=WIP+61633&sxsrf=ACYBGNT6BuoR8e8Y8hxe1pTEjjComhk8EA:1568863900763&source=lnms&tbm=isch&sa=X&ved=0ahUKEwjQ04W8-dvkAhVIgp4KHc87CHQQ_AUIFCgD&biw=1067&bih=690#imgrc=z6SdY7AJ7ekOJM:

I sent a few sets to my buddy in australia ,,, they fit perfect ..

the issues I see on my 68 69's is.....

the spring on the under side that holds tension against the windshield rusts ... when they rust the gap in the spring
goes away and the pulling tension is gone ....

also when they get week ,,, the drivers side will rub on your hood chrome trim .... and the wiper arm will show a black mark right on the elbow ....

also the flat arm drivers side lock clip should be examined very closely... slide the clip back gently ,,,,
sometimes you need to tap lightly with a screwdriver on the lip of the clip and slide it back....

slide it back and check the "PIN" slot that the clip rides in ,.,,, some time with use I have seen them cut right
thru the groove the clip sits in and the wiper arm goes BONKERS and screws up alot a stuff..
windshields.. trim ... wiper arm .... and you cant see because u need the wipers...

please watch a you tube video if you never pulled a wiper arm off a GM like this ... theres a bit of a trick
to keep from scratchin things up put a rag under your pry tool ...

Scott
 

Attachments

·
Registered
Joined
·
99 Posts
Discussion Starter #7
Awesome, thanks very much for the help, and time you put into this! Yea, after a long battle finally getting the wiper wired right, and replaced, the rubber blade has been actually slipping out of the metal arm, and so like many other things on my new goat, my plan is simply to replace it, to make it my own! At first I was just looking for a new rubber blade, assuming there is something missing from my current one that is allowing it to slip out, but based on this I’ll just get new arms and blades together. Not that I ever intend for it to go out in the rain anyway! Thank you!
 

·
Registered
Joined
·
906 Posts
your welcome ...

I just happend to be in the tub next to it and remembered your post...
and pulled em out for pics

just blade and blade holders ... is all youlle need ...

keep YOUR arms ....if they feel nice and springee towards the windshield

easiest if the wipers are in the ..at rest down position if you need to remove them
 
1 - 8 of 8 Posts
Top