Pontiac GTO Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
My 05 GTO has been sitting for almost a month while I have been installing UPP twin turbos. Well got to the point last night where I needed to fire it up to finish adding coolant/water and check.oil level. Battery was relocated to trunk due to lack of engine bay room with 0 gauge wire. Put key in and turned and dash would dim when key turned. Figured battery was weak (6 yr old optima) so I attempted to jump start it with same results. So I took battery to Advanced where they checked it. Came up unstable/bad cell. So I bought new one and took it home and installed. Now here is what is happening;
Interior dome and door and under dash lights work
Key fob when clicked lock/unlock parking lights flash but locks don't operate
Put key in ignition and turn nothing happens.... I mean nothing dash doesn't even light up or radio power up. Only light in cluster that is lite is the car/lock red flashing icon. Has me baffled. I have rechecked ground connection (frame sanded to bare metal).

Any suggestions or ideas?

I have checked ALL dash/engine bay fuses... all good.

I am completely baffled.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
Rechecked all fuses this morning in the light... none are blown. Headlights, interior dome/door lights, parking lights all work. But nothing anywhere else (pwr seats,windows, mirrors). Putting in the key doss not cause the usual chimming when doors are open, and turning it does not cause instrument cluster to wake up or radio/clock to illuminate.

Could the computer be fried? Could the old battery having bad cell/unstable caused all of this? Seems if it had been a short some fuse would be blown.

Checked voltage at battery (12.66v) and at fuse box (12.38v) doesn't seem to be lack.of power.

Thought it might be antheft being stupid and went to check with HP tuners but must have ignition tuned on for HP to read and turning key obviously doesn't cause ignition to come on now.

Bad ignition switch? Bad computer? Short somewhere? Second bad battery? Anyone?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
I assume it did come fully charged. I checked its voltage and it was 12v+. Also charged it with 10 amps for 20-30 minutes with no change in results. How else should I check to make sure it is battery?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Opened car tonight and all hazard lights, interior lights (except dash), and horns flashed until clicker on key fob was clicked unlock. So plenty is still working.... just nothing tied to ignition being switched on. My tuner friend thinks it could be a bad bcm? Maybe shorted when bad battery was misfiring? But he is only guessing. Would power seats usually work with key turned off? I would think so... but they are not working.
Still baffled... feeling helpless.
 

·
Registered
Joined
·
163 Posts
Check out the Sticky on this site for a possible easy fix for the BCM Wiring harness...common problem with these cars. IMO I believe it has something to do with the BCM like your tuner buddy.
 

·
Registered
Joined
·
249 Posts
I'd take it to a GM dealer; know it'll be more expensive but at least you've got a better chance for the right diagnosis.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #12
Short of towing half complete car an hour how does one go about diagnosing bcm problem? Can it be replaced at home if it is the culprit?
 

·
Registered
Joined
·
2,632 Posts
Is the security LED on the dash blinking all the time?
Even when the key is in the ign?
The security LED is supposed to blink even with the key in the ignition until you turn it to the full on position (just before the start position). The BCM can be changed at home but it will have to be progammed to the car with a Tech 2.
 

·
Registered
Joined
·
621 Posts
I'd try connecting the battery close to the starter to be certain I wasn't losing current due to the length of the wiring from the trunk.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #17
I checked BCM wiring behind glove box... all looks perfect with no rubbing or chaffing. I am going to hook battery up up front and make sure that it isn't lack of current. But I would think the 0 gauge wire that came with kit would be more than sufficient. Could I take BCM out and have dealership check just it? If not and I can change BCM at home, but required dealership to program.... would changing it at home help any? IE would it allow car to do anything?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #18
HP11... security LED (car/lock) blinks no matter what position the key/ignition is in. Putting key in and turning it does absolutely nothing! It changes nothing.... like I am not doing anything. If I didn't know better I would think the ignition cylinder was bad.... but if that were the case the power seats and locks would still work. Wiring is most peoples first suggestion, but I don't see how the wiring was "good enough" to cause dash to light up and led readout to illuminate before battery swap, but not now with a new and better battery. I am leaning more towards the BCM or some other electrical component. Just wishing there was a good way to check it to insure it is the problem. Kind of scares me taking my car which is almost through with the twin turbos, but still lacking correct amount of coolants, oils, new larger injectors, and correct tune to the dealership where I don't know anyone of the advisers or techs. All it would take is them fixing it and letting it run/revving it up and screw up the whole [email protected]
 

·
Premium Member
Joined
·
838 Posts
I've looked over the schematics and here are a few things to check:

In the under hood fuse panel check the Engine and the Main 60a fuses and
check that they have 12v on the fuses. Check the BCM/Engine Control 15a fuse and
the Engine Sensor 15a fuse.
Check the mini relays, replace them one by one with a known good one.
If you grounded the battery in the trunk to the frame, make sure you have
a ground from the frame to the engine.

You say the fob blinks the parking lights, clicks, cuts of the alarm, but doesn't unlock the door.
Does the security LED go off when it clicks to try to unlock the door? It should.

Larry
 

·
Registered
Joined
·
30 Posts
Discussion Starter #20
AlaGreyGoat security LED does not go off when keyfob is clicked.

I will go through all the relays and fuses again Wednesday when I am.off during daylight.
 
1 - 20 of 26 Posts
Top