Pontiac GTO Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My son's 2006 GTO AC has not worked for the last year and a half. I put my gauges on the system and Vacummed it down and it shows it has a small leak. I bought some leak fixer and put that into the system and then added Freon and the Car is still blowing hot air. Is there something that I am missing? Do I need to clean the Condenser by spraying coil cleaner on it? Or is there fans that cool down the condenser that I need to check. The Compreser works great no funny sounds and the clutch is engaged all the time when we have it on max. I would really like not to spend to much money my son is wanting to sell this car soon to get a truck.

Thanks
 

·
Registered
Joined
·
352 Posts
I had an issue for a while where one of my fan relays died and wasn't allowing the fans to go into high speed. My AC would blow warm as soon as I came to a stop as there wasn't enough air from the fans to keep the condenser cool enough. So make sure both of your fans are working properly in low speed and in high speed.

Beyond that, here's a comprehensive thread on the A/C system that will help you way more than I can:

How A/C diag is done in the real world - LS1GTO.com Forums
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks I will try that. I know my son's GTO had the front to Grill pieces broken out for a few years until we replaced them. That could make the condenser dirty also. Where exactly are the Fans are they between the Condenser and the front of the car? I did have to remove the top plastic protection piece that is on top of the condenser and radiator to get to the High side valve. But I don't remember seeing any fans, I wasn't really looing for a fan so it that is where they are I can check out the relays and make sure they are running properly

Thanks again
 
1 - 3 of 3 Posts
Top