Pontiac GTO Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
Ok, so earlier this week my Service Engine Soon idiot light comes on and I figure it's about time to have the dealer look at my small list of problems. The passenger seat didn't recline (power motor didn't work), and the front tie rod end & sway bar link spontaneously loosened themselves. Simple fixes, right? I just got a call from the dealer, he said the SES light fixed itself, but could't recall what the code was. I talked to the service writer, not the technician. Anyway, he goes on to tell me that my car wasn't going to be ready until tomorrow. So I ask him why... Turns out that the tech decided to re-flash my computer. I recall some previous discussions about the problems with re-flashing the computers on these cars... And I don't recall them turning out well. The service writer told me that the tech reflashed the computer today and then the car wouldn't start. So apparently it's going to take a little more time to get the computer running again.

Let's take bets. Who thinks I'll actually get my car back tomorrow? I don't....
 

·
Registered
Joined
·
746 Posts
I don't think you will either. I just don't understand why they don't ask your permission before they reflash you computer. Sorry.
 

·
Registered
Joined
·
12 Posts
i work over at an AUDI dealer and we do recall flashes all the time and never have problems like that... so it could be posible that some ppl dont now wat there doin. also it could be that gm has a fault in there flash. but good luck with you situation.
 

·
Registered
Joined
·
491 Posts
It's probably something to do with reprogramming the ignition key? If that's the case, Snap-On's MODIS doesn't have a problem with the procedure, so their Tech2, or whatever the Dealership is using, shouldn't run into any snags getting your car started.
 

·
Registered
Joined
·
344 Posts
Pontiac Dealer Service = Trouble. Im still having Trouble from 8 months back! I wish Chrysler would flash my PT. Seriously Good Luck
 

·
Registered
Joined
·
69 Posts
Discussion Starter #6
Well, believe it or not, I actually got my GTO back today. The dealer was able to complete the computer re-flash and didn't screw anything up. I thought for sure that it was going to be at least a week before I'd see it again, but everything is back and working fine. I will have to take the car back in later next week because the dealer had to order my tie-rod end and parts to fix the seat, but I'm just impressed that the computer re-flash didn't take weeks, like it has for others here.

So, I guess I lost my own bet. And believe me, this is one bet I'm glad I lost...
 

·
Registered
Joined
·
12 Posts
oh yea and you also cant really belive your service advisor.. most of the time they have no clue wat there tlkin about
 
1 - 8 of 8 Posts
Top