Pontiac GTO Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Has anyone had anitfreeze leak from the hose on the motor? Mine is leaking at high speeds, now my light reads low coolant??? The coolant reservior is full???? I will be taking to the dealer.
 

·
Registered
Joined
·
590 Posts
put the K&N CAI in last Thursday and got to see more of the front engine, since you have to remove the black radiator cover and oem air box (duh)

Anyway, no leaky here
 

·
Registered
Joined
·
98 Posts
Just a quick note. Did you use the K&N oiled filter with your CAI? If you did there is a service bulletin not to cover under warranty the MAF or O2 sensors as a oiled air filter element can poision both. Just a thought.
 

·
Registered
Joined
·
590 Posts
GTO TOO said:
Just a quick note. Did you use the K&N oiled filter with your CAI? If you did there is a service bulletin not to cover under warranty the MAF or O2 sensors as a oiled air filter element can poision both. Just a thought.
Yes, the K&N CAI comes with new plenum, heat shield, and big cone shape K&N.

I ran K&N on my 02 SS Camaro and '94Z28

I'm aware of possible warranty problem but had zero problems, no SES lights, you just can't over oil them that oil will get on MAF screen and code the engine amongst other problems that can happen. MOST dealers won't give you warranty problems, now you go burn a piston and come in with a oil coated MAF screen and intake and I"d say you'd have a problem.

The friggin GTO lifts higher and sounds like a beast. Haven't dynoed but from the seat of the pants, it's pullin harder.
 

·
Registered
Joined
·
39 Posts
GTO TOO said:
Just a quick note. Did you use the K&N oiled filter with your CAI? If you did there is a service bulletin not to cover under warranty the MAF or O2 sensors as a oiled air filter element can poision both. Just a thought.

That is not what the bulliten says. It states that if the K&N filter is serviced and over oiled it can cause contamination of the engine and cause pre-mature failures of the engine.

The bulliten advises tech's to check the airduct system for oil residue if they suspect the filter to cause damage.
 

·
Registered
Joined
·
49 Posts
heatherGTO said:
Has anyone had anitfreeze leak from the hose on the motor? Mine is leaking at high speeds, now my light reads low coolant??? The coolant reservior is full???? I will be taking to the dealer.
No leaks here. There is a fairly common problem with leaks from the freeze plug on the front of the passenger side head.
 
1 - 6 of 6 Posts
Top