Pontiac GTO Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Everytime it rains and I apply my brakes the driver side like hops or vibrates sort of feels like I have a flat. It only does it when it rains. Is this normal? Is this the ABS kicking in? I just had my tires rotated and they said the brakes look fine. Does anyone else have this issue. It an 05 auto.
 

·
Registered
Joined
·
3,765 Posts
Could be # of things. Bad alignment, not balanced tire, bad rotor, not torqued logs, suspension issues....
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
even with it only happening in the rain? So I'm guessing its not the ABS? I just had my tires rotated and balanced and it still does it and they didnt see anything wrong with the brakes....maybe I need to take it somewhere else and I guess take it when it rains!!
 

·
Registered
Joined
·
3,765 Posts
If it is only in the rain it could be a lose of trackion and the ABS kicking in. How hard are you are you hitting the brakes to set it off? What kinda tires? Decent tread left? Stock rotors/pads?

I think our guages will tell you when the ABS kicks on with a light or message. I'll test it on my way home. We have a backroad that I can easlily go 100+ and then slam the brakes. I'll let you know if I get any message or lights when it kicks in.

I did ear stories about the A4s when hitting the brakes really hard the 3-1 shift can kick them lose(rears though) but that was mostly with factory 18s cause the summer onlys sucked.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Tires are fairly new maybe couple months old they are General UHP ....I think thats what there called. Stock pads and rotors (I guess) I'm the second owner. It had 15k on it when I purchased it and now it has 21k. It's like maybe a pad is getting wet in spots and when I brake it hits those wet spots?? I'm not braking hard at all just enough to slow down a lil before I come to a stop and thats why I don't brake hard when it rains because I know my brakes are going to do that.
 

·
Registered
Joined
·
531 Posts
I've got a similar issue. It started more when it was wet out, but it's now happening sometimes when it's dry. I was told my tie rod ends need to be replaced... getting that done next weekend.
 

·
Registered
Joined
·
25 Posts
I have the same issue in my 06 but only noticed when it rains and when im going down a hill. i balance my tires every 6k and keep up on all the maintenance. I was thinking about a abs delete but dunno if that is such a good idea. Maybe someone will be able to find a solution to this i hope. Im doing a Energy suspension master bushing kit this spring when i get it out of storage. We shall see if this helps.
 

·
Registered
Joined
·
6 Posts
I have Hawk ceramics and when they are wet after a few miles of no brakes, they take a bit of modulation to start working, on stock, warped rotors. Maybe its just pad knockback though, not sure. Do you have stock Radius Rod bushings?
 

·
Registered
Joined
·
2,632 Posts
You guys drive you GTOs in the rain????:)
 

·
Registered
Joined
·
3,765 Posts
You guys drive you GTOs in the rain????:)
Rain is nothing. Mine get snow and salt too! GTO is my bad weather vehicle, good weather is the bike :)
 

·
Registered
Joined
·
78 Posts
My cars have almost ALL had this problem.... Not unique to the GTO.

When the rotor's wet, and you lightly step on the brake, the pad keeps floating on the wet disc. Push harder and it will sound worse until the water film breaks down or boils off... but then it will stop the 'vibration'.

Maybe it's related to the rotor/pad geometry or something... But I doubt it's related to balance, tie rods, or anything mechanical. My GTO (and other cars) have done it since new.

BOB
 
1 - 12 of 12 Posts
Top