Pontiac GTO Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey boys I need help. I have a little under 4 hours to extract a broken bolt from the thermostat housing, replace the thermostat gasket, thermostat, and refill it with Dex. Any ideas aside from removing the whole water pump or the fan and housing? As you know there is about 4 inches of space to get a drill into with an extractor on it...so far nothings working!!!:confused
 

·
Registered
Joined
·
3,765 Posts
I'm guessing your an LS2? I don't remember my LS1 t-stat housing being in a hard to reach place.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yeah ls2. I just yanked the housing & the fans out so now I can reach it but man it was a bear. Hopefully this works. You're an ls1? Have you had a problem with the car overheating after you've changed the pump, therm, and hoses? Mine won't stop.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Yeah that's the problem tho. My boyfriend has my Dak & I gotta be somewhere at 3 so not a bunch of time. Are u ls1 or ls2? I think I got it but we'll see. Thanks y'all!
 

·
Registered
Joined
·
3,765 Posts
Did you check your rad cap? I know the LS2 has one. I have a pressurized overflow instead.

I'm also seen several Pep Boys t-stats out of the box not work. I've personally had good luck with Advance Auto Parts stuff. They have failsafe ones that if they do fail, they get stuck open so you don't dump coolent everywhere.

Are you losing coolent? Any white smoke? Does you oil still look like oil?
 
1 - 5 of 5 Posts
Top