Pontiac GTO Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
Not sure exactly where to post this, but it probably doesn't matter anyway. I stand a good chance of it being taken down and maybe even myself being banned, but I don't care. First and foremost, this is a nice site to come to. Very knowledgeable and experienced members, all willing to share. But, none of this does me or anyone else any good, if we can't log on. Occasionally, I find for some reason, I've been kicked off. I then attempt to log back on using my previous password which isn't accepted. I then have to apply for a new password and the method is totally ridiculous. First, you have to look at the most grainy, distant photos, ink blocks, in an attempt to find something they are looking for. If you fail that, you get another chance. Then another chance. Then another chance. Up to 5 attempts and then a timeout for about 15 minutes. Even if you happen to eventually be successful, they assign you a new password that doesn't work either. You'd have an easier time remembering the password to the Fort Knox Mint, then this password. This way of doing things is passe. Archaic. Antiquated. And don't try sending them an email. It comes back either undeliverable or it's weeks later when they respond. By that time, you forgot the original question. I'm a member of 5 other car sites including PY. None do it this way. We aren't assigned a password. We pick our own. So simple and effective. Not sure what this site is trying to protect by doing it this way, but it is the absolute worse site to log onto. I don't post much, because I don't know much. But I have seen a few past issues that I would have commented on and perhaps had been helpful, if I could get on. Some might think that if I don't like it here, then leave. Sure. I could do that. But, that's the easy way out, isn't it. Why not fix the problem first. Guess I got lucky today; maybe. Only took one attempt, Nicholas.
 

·
Administrator
Joined
·
323 Posts
Hi there,

Seems like there's a corrupted cookie on your browser.
For starters, I would suggest clearing your caches and cookies.
The next time you log in, click "remember me" and you should be stayed logged in.

Ed
 
1 - 2 of 2 Posts
Top