Pontiac GTO Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
Howdy all I am having some problems.... again! I posted about 2 years ago and you all were spot on in your diagnosis.

Anyways my new problem is a bit odd. Whenever I press on the gas it stalls like it's going to die and then kicks back in and keeps on going. It's almost like a stutter. This happens any time I stop and I thought I wasn't going to make it home the other day. The car is running, but again it's not sustainable and I'm motivated to get her back in shape.

I thought I would come here for a diagnosis before some DIY work on her. My initial thoughts is that it could be a timing issue. I put a new fuel pump on less than 2 years ago. I don't think that the pump is bad as I haven't hardly driven it. Regardless any help is much appreciated and I'll post some pictures of her tomorrow.

Thanks ahead of time!:willy:
 

·
Registered
Joined
·
1,116 Posts
If you have a good steady idol, it probably is not the timing. Pull the plugs to see if they are fouled. How old is the gas? You may have some water in there and I hope you are using a good premium grade.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #8
I will start with a quick cleaning of the jets and go from there. I run 93 and there wasn't any old gas in the car at all. I started it up today and ran it about 2 miles and there was no problem and I took a right turn and it started back up again.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #11
Thanks to all you guys that said it was the accelerator pump as always you were spot on and I was able to knock it out myself. This is the 3rd problem I've had your guy's help in diagnosing and fixing. I also was able to get my front turn signals up and going again after doing some searches on here!
 
1 - 11 of 11 Posts
Top