Pontiac GTO Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I replaced my old carter qjet w/a new edlebrock 600 electric choke. I know its a little under power for the 400 but is was a deal I couldn't pass up.
Anyway the car now starts find, runs ok but the carb will not open fully.

The only thing I can think is the linkage cable is too long there is slack near the carb. Is there anyway to tighten the cable w/out replacing the linkage?

Or is it another problem & I'm too dump to see it. :willy:
 

·
Registered
Joined
·
16 Posts
Discussion Starter #2
I found the problem. I needed a larger adapter plate. This GTO forum has either the most unfriendly members or a bunch of guys who know little about their own car. I belong to the Corvette forum and asked the same question and got 6 replies the same day. Thanks GTO members. I bet you guys don't wave to each other on the road as you pass by. :seeya:
 

·
Registered
Joined
·
42 Posts
jim,
Hey what,s up? There are a couple of guys that always answer questions, It just may take a couple of days. This is a good forum and hope you have better luck next time. I also belong to the corvette forum. It looks like we both have 1968 gto,s. I have a 1999 corvette. do you have a vette, and what year? Also where are you from?
matt
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
matt68gto said:
jim,
Hey what,s up? There are a couple of guys that always answer questions, It just may take a couple of days. This is a good forum and hope you have better luck next time. I also belong to the corvette forum. It looks like we both have 1968 gto,s. I have a 1999 corvette. do you have a vette, and what year? Also where are you from?
matt
Hi Matt just blowing off steam on the above thread. I guess there are a lot more classic Vette's on the road then GTO's. I have a 79 which I restored and modified. I'm looking for a set of aluminum heads for it right now. I live along the NJ Shore. A lot of salt air so I'm fighting rust everyday. I would love to pick up a 95 to 99 convertible 6 sp. I know a lot of the C3 guys don't like the newer Vette's but I like them all. And if I had a boat load of cash I would buy a 2006 Z06 vert today. Thanks for letting me know there are actual members on this side of the fence.
Jim :cheers
 

·
Registered
Joined
·
42 Posts
jim,
I'm with you on that new z06. Way to much money for my blood. Maybe in 6yrs. when the price comes down. Your vette sounds nice. I have an appreciation for all of them. I just went to the bloomington gold a few weeks ago. I am lucky because the show is so close to my house. If you ever get the itch to go to that show look me up.
What kind of shape is your 68 GTO in, and is it some what original or built? Also what color, and does it have the hide away headlights? Have a good one, later.
matt
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
matt68gto said:
jim,
I'm with you on that new z06. Way to much money for my blood. Maybe in 6yrs. when the price comes down. Your vette sounds nice. I have an appreciation for all of them. I just went to the bloomington gold a few weeks ago. I am lucky because the show is so close to my house. If you ever get the itch to go to that show look me up.
What kind of shape is your 68 GTO in, and is it some what original or built? Also what color, and does it have the hide away headlights? Have a good one, later.
matt
Matt, its a 67 vert (jims67 was taken) its white w/black interior. Mostly stock but I put in a muncie M22 and posi-rear w/355 gears and heavy duty clutch. I upgraded the suspenision on all four w/new performance springs & KYB shocks. Also put Thrush D mags & Red line wide oval tires 225/70/15 up front and 255/60/15 on the rear. Then I detailed the engine its all black & chrome and added wood dash & steering wheel and all new white face gauges and a USA-6 400watt stereo w/10 CD player in the trunk w/two 10" sub-woofers. (the USA Stereo is from Custom Audio Sounds and it looks like the factory AM/FM in dash. Again everything is Black & Chrome. The last thing a added was black pin stripes on the side & large black GTO emblem on the front fender behind the wheel. I'll post a pic soon.
Jim
 
1 - 6 of 6 Posts
Top