Pontiac GTO Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am continually receiving a check engine light on my stock 04 GTO. When the OBDII reader is plugged up, I get a p0442 code. When code manual referenced, it says it is this is a emission leak. I have been told this is common due to bad gas cap. It's been replaced and still get check engine light couple days after erasing code. What else to consider???
 

·
Premium Member
Joined
·
838 Posts
May want to check the vacuum hoses on the charcoal canister between
the rear wheel. It's next to the rear end chunk. I knocked a hose off mine
while mounting my airbags, and had the same problem you are having.

Larry
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Is the charcoal canister black, rectangular looking box? Thats the only thing I see with some hoses coming out of it. If so, they seem pretty snug....
 

·
Registered
Joined
·
235 Posts
Yep thats the cannister
 

·
Registered
Joined
·
3,765 Posts
Probally the gas cap. I'd replace it again. As small of a leak that is needed to cause the CEL, you will have a tough time finding it without a gas test.

My old Sebring had this CEL and it ended up not being the gas cap. Took it to a good shop and they ran the gas test 3 times and couldn't find the leak. I got pissed and just put zip ties on the end of each hose back there and my problem was fixed. Guessing it is because they glue the hoses rather then clamping them. Maybe the glue doesn't last forever.
 
1 - 7 of 7 Posts
Top