Pontiac GTO Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter #1
i was turning the steering wheel and i heard this popping noise. not smooth. like something was missing in the suspention or steering. thanks Ralph
 

·
Registered
Joined
·
91 Posts
just when you turn the wheel while stopped? while moving?speeds? make noise over bumps or rough road? A little more info needed for any real id of the cause of the noise.
 

·
Registered
Joined
·
197 Posts
Discussion Starter #4
only when stopped. thanks, that was good reading material
 

·
Registered
Joined
·
91 Posts
I get a little sproing sound while I'm turning into my parking spot, so basically turning while almost stopped. It occurs at the very far end of the rotation to the right. It happened before I changed the spring, struts, bearings and it still happens. Not a horrible clunk or pop just a little pop/clunk. Im thinking it has to be something attached to steering.
 

·
Registered
Joined
·
197 Posts
Discussion Starter #8
well, i was having my tranny replaced anyway so i told the mechanic to check the steering linkages and he went around tightening things. he didnt tell me if he found something, but its not making the noise anymore. go figure. thanks again guys.
 

·
Registered
Joined
·
6 Posts
He may have tightened up on your Radius Rod Nuts. If you hear it any more or your front end feels mushy while negotiating turns,then you may want to replace them with urethane bushings.I had the same problem and I just changed mine.Now it handles like a vette, and of course no more noise.
 

·
Registered
Joined
·
197 Posts
Discussion Starter #10
will keep a ear open. if so who's did you use? pedders
 

·
Registered
Joined
·
12 Posts
i got a popping sound after i hit a toco patch job in the road

After running over a sunken patch job in the road i got a popping sound in my front end sounds like a spring is turning in the strut but it goes away after a few turns ?? she is all stock to..60k if that is the case ill cut some heater hose to cover the lower part of the spring and see if i get the sound and upper ?? ill know more when i get it on the lift ...ill update when i find the issue...:shutme
 

·
Registered
Joined
·
12 Posts
Today i put the GTO on the lift to see if i could that noise and i found that my sway bar end links was bad the rubber was gone and link was just hanging there ?? the spring looks ok not moving like i thought anyways I'm only at 62k so whats up with that!!
 
1 - 12 of 12 Posts
Top